<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Introduction</td>
<td>6</td>
</tr>
<tr>
<td>1.1 MotiveWave™ Editions and Modules</td>
<td>6</td>
</tr>
<tr>
<td>1.1.1 Editions</td>
<td>6</td>
</tr>
<tr>
<td>1.1.2 Modules</td>
<td>6</td>
</tr>
<tr>
<td>1.2 Starting MotiveWave™</td>
<td>6</td>
</tr>
<tr>
<td>1.3 License</td>
<td>8</td>
</tr>
<tr>
<td>1.3.1 Changing your License Key</td>
<td>8</td>
</tr>
<tr>
<td>1.3.2 License Status</td>
<td>9</td>
</tr>
<tr>
<td>2 Console</td>
<td>10</td>
</tr>
<tr>
<td>2.1 Preferences</td>
<td>14</td>
</tr>
<tr>
<td>2.2 Workspaces</td>
<td>15</td>
</tr>
<tr>
<td>2.2.1 Professional/Ultimate Editions</td>
<td>16</td>
</tr>
<tr>
<td>2.2.2 Single Broker Editions</td>
<td>18</td>
</tr>
<tr>
<td>2.3 Changing the Default Layout</td>
<td>18</td>
</tr>
<tr>
<td>2.3.1 Creating a new page</td>
<td>19</td>
</tr>
<tr>
<td>2.3.2 Modifying a Page</td>
<td>19</td>
</tr>
<tr>
<td>2.3.3 Changing the Page Order</td>
<td>20</td>
</tr>
<tr>
<td>2.3.4 Resizing Panels</td>
<td>20</td>
</tr>
<tr>
<td>2.3.5 Adding New Panel Tabs</td>
<td>21</td>
</tr>
<tr>
<td>2.3.6 Creating a Custom Layout</td>
<td>22</td>
</tr>
<tr>
<td>2.4 Changing the Look and Feel</td>
<td>23</td>
</tr>
<tr>
<td>2.5 Instruments</td>
<td>26</td>
</tr>
<tr>
<td>2.5.1 Importing Instruments</td>
<td>27</td>
</tr>
<tr>
<td>2.5.2 Trading Hours</td>
<td>28</td>
</tr>
<tr>
<td>2.6 Watch Lists</td>
<td>30</td>
</tr>
<tr>
<td>2.6.1 Watch List Tool Bar</td>
<td>31</td>
</tr>
<tr>
<td>2.6.2 Sorting Options</td>
<td>31</td>
</tr>
<tr>
<td>2.6.3 Buy/Sell Boxes</td>
<td>32</td>
</tr>
<tr>
<td>2.6.4 Create Watch List</td>
<td>33</td>
</tr>
<tr>
<td>2.6.5 Edit Watch List</td>
<td>35</td>
</tr>
<tr>
<td>2.7 Quote Sheets</td>
<td>36</td>
</tr>
<tr>
<td>2.8 Backup/Restore</td>
<td>39</td>
</tr>
<tr>
<td>2.8.1 Creating a Backup</td>
<td>39</td>
</tr>
<tr>
<td>2.8.2 Restore From Backup</td>
<td>39</td>
</tr>
<tr>
<td>2.9 Repository</td>
<td>40</td>
</tr>
<tr>
<td>2.9.1 Sharing using Google Drive or Drop Box</td>
<td>42</td>
</tr>
<tr>
<td>2.9.2 Folder Structure</td>
<td>42</td>
</tr>
<tr>
<td>2.9.3 Analysis Sources</td>
<td>43</td>
</tr>
<tr>
<td>2.10 Email Configuration</td>
<td>45</td>
</tr>
<tr>
<td>2.10.1 Gmail</td>
<td>46</td>
</tr>
<tr>
<td>2.10.2 Yahoo Mail</td>
<td>46</td>
</tr>
<tr>
<td>2.10.3 Windows Live / Hotmail</td>
<td>46</td>
</tr>
<tr>
<td>3 Charts</td>
<td>48</td>
</tr>
<tr>
<td>3.1 Settings</td>
<td>49</td>
</tr>
<tr>
<td>3.1.1 Default Chart Settings and Options</td>
<td>49</td>
</tr>
</tbody>
</table>
3.1.2 Chart Specific Settings 52
3.2 Price Indicators 53
3.3 Chart Spacing 54
3.4 Bar Sizes 55
3.4.1 Custom Bar Sizes 56
3.4.2 Bar Size Selector 57
3.5 Importing Data 58
3.6 Exporting Data 59
3.7 Bird’s Eye View 60
3.8 Cursor Data 60
3.8.1 Cursor Data Window 60
3.8.2 Cursor Data Panel 61
3.8.3 Bar Status 62
3.8.4 Hover Popup 62
3.8.5 Cross Hair 62
3.9 Time & Sales 64
3.10 Depth Of Market (DOM) Panel 65
3.11 Chart Labels 66
3.12 News 68
3.13 Watermark 69
3.14 Scaling 70
3.15 Analyses 71
3.15.1 Creating a New Analysis 72
3.15.2 Open Existing Analysis 74
3.15.3 Manage Analyses 74
3.15.4 Import/Export Analyses 74
3.16 Components 76
3.16.1 Components Panel 76
3.16.2 Adding a Component 76
3.16.3 Selecting Components 78
3.16.4 Deleting a Component 79
3.16.5 Component Properties 80
3.16.6 Working with Trend Lines 81
3.16.7 Custom Tools 84
3.16.8 Tool Groups 88
3.16.9 Visibility 90
3.16.10 Object Viewer 91
3.17 Ratios 92
3.17.1 Customized Ratios 94
3.17.2 Ratio Display Preferences 95
3.17.3 Ratio Presets 95
3.17.4 Global Ratio Preferences 97
3.18 Time/Price Guides 98
3.19 Percent Change Charts 99
3.20 Studies 101
3.20.1 Adding a Study 102
3.20.2  Editing a Study
3.20.3  Study Options
3.20.4  Signals
3.20.5  Instrument Overlay
3.21  Strategies
  3.21.1  Manual Strategies
  3.21.2  Strategy Configuration
3.22  Software Development Kit (SDK)
3.23  Tool Bar
3.24  Lock Studies
3.25  Lock Scroll
3.26  Study Templates
  3.26.1  Removing a Template
  3.26.2  Managing Templates
  3.26.3  Import/Export Templates
  3.26.4  Template Preferences
3.27  Linking Charts
  3.27.1  Linking With Templates
  3.27.2  Link All
3.28  Working with Chart Windows
  3.28.1  Compact Mode
  3.28.2  Tile Windows
  3.28.3  Cascade Windows
  3.28.4  Window Sizes
3.29  Replay Mode
  3.29.1  Replay Settings
  3.29.2  Linking in Replay Mode
3.30  Alerts
  3.30.1  Price Alerts
  3.30.2  Study Alerts
  3.30.3  Component Alerts
  3.30.4  Trading From Alerts
  3.30.5  Advanced Alert Settings
  3.30.6  Alert History
  3.30.7  Alert Preferences
3.31  Ticker Tape
3.32  Short Cuts
  3.32.1  Menu Short Cut Keys
  3.32.2  Mouse Wheel
  3.32.3  Mouse Click Options
  3.32.4  Other Shortcuts
4  Trading
  4.1  Account Management
    4.1.1  Account Panel
    4.1.2  Orders Panel
    4.1.3  Positions Panel
4.1.4 Trades Panel 155
4.2 Simulated Account 156
4.3 Commissions 157
4.4 Order Presets 158
4.5 Chart Trading 160
  4.5.1 Chart Orders 160
  4.5.2 Trade History 162
  4.5.3 Price Axis Trading 162
  4.5.4 Buy/Sell Buttons 164
  4.5.5 Context Menu 166
  4.5.6 Trade Panel 166
  4.5.7 Preferences 172
4.6 Depth Of Market (DOM) 174
  4.6.1 Trading From the DOM 175
  4.6.2 Position Panel 178
  4.6.3 Centering 179
  4.6.4 Preferences 179
4.7 Option Chains 180
  4.7.1 Placing and Managing Orders 180
  4.7.2 Option Spread Strategies 182
  4.7.3 Preferences 182
5 Desktops 184
  5.1 Changing Desktop Layout 186
6 Scanner 187
  6.1 Creating a Scan (Gartley Scanner) 187
  6.2 Executing a Scan 189
  6.3 Editing a Scan 190
  6.4 Elliott Wave Scanner 192
  6.5 Study Scanner 194
7 Strategy Back Testing 199
  7.1 Creating a Strategy Analysis 199
    7.1.1 Strategy Settings Panel 200
    7.1.2 Choose Instruments Panel 202
    7.1.3 Data Settings Panel 202
    7.1.4 Execution Settings Panel 204
    7.1.5 Optimizer Settings Panel 204
  7.2 Strategy Analysis 206
8 Custom Instruments 210


1 Introduction

Welcome to the MotiveWave™ User’s Guide! If you are reading this document then you have already installed MotiveWave™ on your computer and you are ready to start using the application.

If you have not yet installed MotiveWave™ or registered for a trial on our website, please read the Installation Guide before continuing on with this document.

1.1 MotiveWave™ Editions and Modules

If you are currently working with the trial version of MotiveWave™ (available from our website), then you most likely have the Ultimate Edition of MotiveWave™. This edition includes all of our features and functionality (Note: excludes partner modules and studies). If you are currently on a trial and you would like to try a specific edition/module, please contact sales@motivewave.com.

1.1.1 Editions

There are several editions of MotiveWave™ available to address the different needs and budgets of traders and market analysts. Detailed information on these editions and the functionality that they provide can be found on our website: http://www.motivewave.com/purchase/compare-editions.htm

1. Ultimate Edition – This edition includes all of our features and is recommended if you are a professional trader and you are using advanced features such as Elliott Wave, Gann or Gartley.
2. Professional Edition – This is for professional traders that do not used advanced features such as Elliott Wave, Gann or Gartley
4. Trade Edition – Expands on the Charts Edition to provide trading capabilities
5. Charts Plus Edition – Expands on the Charts Edition and adds popular features such as Replay Mode, Chart Templates, Multi-Time Frame studies and more.
6. Charts Edition – This entry level edition contains a full set of studies and basic tools for doing analysis.

1.1.2 Modules

Modules can be added to editions to extend their capabilities. For a full list of available modules and their capabilities see: http://www.motivewave.com/purchase/modules.htm

1.2 Starting MotiveWave™

If you are on Mac OS™, MotiveWave™ will be found from your Launch Pad or in your Applications folder. Just click on the MotiveWave™ icon to start the application. If you installed MotiveWave™ on a Windows™ machine double click on the MotiveWave™ icon on your desktop. Alternatively, choose Start -> All Programs -> MotiveWave -> MotiveWave.exe

The first screen that you will see when you start MotiveWave is the startup screen. Normally you will open a workspace from this screen. Select the workspace from the drop down and press the Continue button.
Depending on the broker or data service that you have chosen for the workspace, you may see a dialog that asks for login information. The example below is a login dialog for a CQG workspace. In this case enter your User ID and password for your CQG account.

**Please Note:** there is no user name or password for MotiveWave™, just a license key. If you are being asked for a login ID and password, then this would be for the broker or data service that you chose for the workspace.
1.3 License

When you create a trial for MotiveWave™ from our website, you will be sent an email that contains a license key. This key will need to be entered as part of the installation process (see the Install Guide). This license key uniquely identifies your profile and will not change (even when you purchase).

If you think this key has been compromised, you can send a request to our support team (support@motivewave.com) to request a new key. This key will be sent to the email address that you registered with.

1.3.1 Changing your License Key

Your license key can be changed from the startup screen in MotiveWave™. From the Options menu button select the Licence option.

Enter your new licence key into the Licence Key field. Press the Update button to validate this key and change the licence key that MotiveWave™ will use going forward. Note: to avoid mistyping the licence key, it is recommended that you copy and paste the key from the email message instead.
1.3.2 Licence Status

You can easily check which MotiveWave™ Edition and Modules that are assigned to your license by choosing Help -> About from the top menu bar of the Console. The About dialog will display your license key, email address, edition, modules and lease/support expiry dates.
2 Console

After you have installed MotiveWave™ and configured your workspace the first window that you will see when opening that workspace will be the Console. The console provides access to all the features in MotiveWave™ and it is initially configured with a default layout.

The console is organized into different **pages** (see screen shot above, please note: pages are only available in the Professional and Ultimate editions of MotiveWave™). To access a different page, simply click on the page tab at the bottom of the console window. The default set of pages are as follows:

1. **Home** – The home page contains a sample layout that has a single chart area and two spots at the bottom for watch lists.
2. **Charts** – Sample layout of 6 charts
3. **Account** – Layout containing information about your account, orders, positions and historical trades.
4. **Options** – Sample layout containing Option Chains. Note: this page is only available on brokers that support options trading.
5. **Scan** – Layout for using the scanning functionality within MotiveWave™
6. **Optimize** – Contains a strategy optimizer panel for Back Testing, Optimization and Walk Forward testing of automated strategies.
7. **News** – If supported by your Broker/Data service, you may see a page for news

The following screen shots illustrate the default set of pages in the console:
### Options Page

#### MotiveWave Console (trader)

**Underlying**: GOOG

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Position</th>
<th>Bid Size</th>
<th>Bid</th>
<th>Ask</th>
<th>Ask Size</th>
<th>Last Price</th>
<th>Strike Price</th>
<th>Last Price</th>
<th>Bid Size</th>
<th>Bid</th>
<th>Ask</th>
<th>Ask Size</th>
<th>Last Price</th>
<th>Orders</th>
<th>P/L</th>
<th>Position</th>
</tr>
</thead>
<tbody>
<tr>
<td>GOOG</td>
<td>3</td>
<td>753.50</td>
<td>753.70</td>
<td>2</td>
<td>752.52</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Buy</td>
<td>6</td>
<td>9.60</td>
<td>10.70</td>
<td>21</td>
<td>9.20</td>
<td>710.00</td>
<td>21.81</td>
<td>19.00</td>
<td>17.90</td>
<td>14</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Buy</td>
<td>6</td>
<td>10.50</td>
<td>11.90</td>
<td>11</td>
<td>12.20</td>
<td>767.50</td>
<td>21.48</td>
<td>14.70</td>
<td>16.50</td>
<td>14</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Buy</td>
<td>8</td>
<td>12.10</td>
<td>13.30</td>
<td>17</td>
<td>11.00</td>
<td>785.00</td>
<td>24.90</td>
<td>13.60</td>
<td>15.80</td>
<td>11</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Buy</td>
<td>6</td>
<td>13.48</td>
<td>14.60</td>
<td>8</td>
<td>12.48</td>
<td>782.50</td>
<td>14.80</td>
<td>12.50</td>
<td>14.30</td>
<td>8</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Buy</td>
<td>8</td>
<td>14.80</td>
<td>16.20</td>
<td>15</td>
<td>13.05</td>
<td>780.00</td>
<td>12.20</td>
<td>11.90</td>
<td>13.10</td>
<td>15</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Buy</td>
<td>6</td>
<td>16.10</td>
<td>17.70</td>
<td>7</td>
<td>10.06</td>
<td>710.00</td>
<td>12.11</td>
<td>11.00</td>
<td>12.10</td>
<td>11</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

#### Scan Page

**Symbol**: AEO, X, CSX

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Bar Size</th>
<th>Scan Time</th>
<th>Pattern</th>
<th>Score</th>
<th>Symbol</th>
<th>Bar Size</th>
<th>Scan Time</th>
<th>Pattern</th>
<th>Score</th>
</tr>
</thead>
<tbody>
<tr>
<td>AEO</td>
<td>1 day</td>
<td>16.01</td>
<td>Wave 2</td>
<td>Fair</td>
<td>CSX</td>
<td>1 day</td>
<td>16.02</td>
<td>Wave 2</td>
<td>Fair</td>
</tr>
<tr>
<td>X</td>
<td>1 day</td>
<td>16.00</td>
<td>Wave 2</td>
<td>Fair</td>
<td>CSX</td>
<td>1 day</td>
<td>16.02</td>
<td>Wave 2</td>
<td>Fair</td>
</tr>
</tbody>
</table>

**Harmonic**:

- **Symbol**: CSX
- **Scan Time**: 16.02
- **Pattern**: Wave 2
- **Score**: Fair
- **Overrides**: Good

**Overrides**:

- 

---

©2019 MotiveWave™ Software
Optimize Page

MotiveWave™ Console Page (trader)

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Parameters</th>
<th>Start</th>
<th>End</th>
<th>Net Profit</th>
<th>Gross Profit</th>
<th>Gross Loss</th>
<th>Executions</th>
<th>Commissions</th>
<th>Max Drawdown</th>
</tr>
</thead>
<tbody>
<tr>
<td>IBM</td>
<td>C.EMA,20,C.EMA,15 (Fast Input) Aug/06/16</td>
<td>Nov/06/16</td>
<td>$590.00</td>
<td>$3,497.00</td>
<td>$1,907.00</td>
<td>83</td>
<td>$0.00</td>
<td>$493.00</td>
<td></td>
</tr>
<tr>
<td>IBM</td>
<td>C.EMA,5,C.EMA,15 (Fast Input) Aug/06/16</td>
<td>Nov/06/16</td>
<td>$119.00</td>
<td>$3,118.00</td>
<td>$2,998.00</td>
<td>154</td>
<td>$0.00</td>
<td>$782.00</td>
<td></td>
</tr>
<tr>
<td>IBM</td>
<td>C.EMA,15,C.EMA,15 (Fast Input) Aug/06/16</td>
<td>Nov/06/16</td>
<td>$0.00</td>
<td>$0.00</td>
<td>$0.00</td>
<td>0</td>
<td>$0.00</td>
<td>$0.00</td>
<td></td>
</tr>
<tr>
<td>IBM</td>
<td>C.EMA,20,C.EMA,20 (Fast Input) Aug/06/16</td>
<td>Nov/06/16</td>
<td>$0.00</td>
<td>$0.00</td>
<td>$0.00</td>
<td>0</td>
<td>$0.00</td>
<td>$0.00</td>
<td></td>
</tr>
<tr>
<td>IBM</td>
<td>C.EMA,5,C.EMA,15 (Fast Input) Aug/06/16</td>
<td>Nov/06/16</td>
<td>$328.00</td>
<td>$2,352.00</td>
<td>$2,080.00</td>
<td>107</td>
<td>$0.00</td>
<td>$797.00</td>
<td></td>
</tr>
<tr>
<td>IBM</td>
<td>C.EMA,5,C.EMA,20 (Fast Input) Aug/06/16</td>
<td>Nov/06/16</td>
<td>$143.00</td>
<td>$2,277.00</td>
<td>$2,135.00</td>
<td>125</td>
<td>$0.00</td>
<td>$522.00</td>
<td></td>
</tr>
</tbody>
</table>

Metrics
- Chart: Reports
- Periods: Trades (103)
- Executions (154)

Strategy: MA Cross
Type: Optimize
Start Date: Aug/06/16
End Date: Nov/06/16
Symbol: IBM
Parameters: C.EMA,5,C.EMA,15 (Fast Input)
Fast Input, Slow Input Method, Slow Period, Slow Period
Bar Size: 5 min

<table>
<thead>
<tr>
<th>Metric</th>
<th>All Trades</th>
<th>Long Trades</th>
<th>Short Trades</th>
</tr>
</thead>
<tbody>
<tr>
<td>Total Net Profit (incl Commissions)</td>
<td>$115.00</td>
<td>$(218.00)</td>
<td>$337.00</td>
</tr>
<tr>
<td>Total Profit (Gross - Loss)</td>
<td>$115.00</td>
<td>$(218.00)</td>
<td>$337.00</td>
</tr>
<tr>
<td>Gross Profit</td>
<td>$1,116.00</td>
<td>$1,252.00</td>
<td>$1,336.00</td>
</tr>
<tr>
<td>Gross Loss</td>
<td>$(2,999.00)</td>
<td>$(1,502.00)</td>
<td>$(1,499.00)</td>
</tr>
<tr>
<td>Commission</td>
<td>$0.00</td>
<td>$0.00</td>
<td>$0.00</td>
</tr>
<tr>
<td>Profit Factor</td>
<td>1.940</td>
<td>0.655</td>
<td>1.225</td>
</tr>
<tr>
<td>Max Drawdown</td>
<td>$876.00</td>
<td>$665.00</td>
<td>$379.00</td>
</tr>
<tr>
<td>Max Drawdown (%)</td>
<td>0.88%</td>
<td>0.67%</td>
<td>0.38%</td>
</tr>
<tr>
<td>Total # Trades</td>
<td>153</td>
<td>76</td>
<td>77</td>
</tr>
<tr>
<td>Percent Profitable</td>
<td>33.98%</td>
<td>30.26%</td>
<td>37.66%</td>
</tr>
<tr>
<td># Winning Trades</td>
<td>52</td>
<td>23</td>
<td>29</td>
</tr>
<tr>
<td># Losing Trades</td>
<td>100</td>
<td>100</td>
<td>100</td>
</tr>
</tbody>
</table>

News Page

MotiveWave™ Console (google)

Time Frame: All
<table>
<thead>
<tr>
<th>Symbol</th>
<th>Released</th>
<th>Time</th>
<th>Source</th>
<th>Headline</th>
</tr>
</thead>
<tbody>
<tr>
<td>GOOG</td>
<td>2016-11-06 07:03 EDT</td>
<td>Profit Confidential</td>
<td>Goog Stock: New Report Is Great News For Alphabet Inc</td>
<td></td>
</tr>
<tr>
<td>GOOGL</td>
<td>2016-04-05 06:28 EDT</td>
<td>Profit Confidential</td>
<td>Alphabet Inc: This GOOG Stock Trend Line is all that Matters</td>
<td></td>
</tr>
<tr>
<td>GOOG</td>
<td>2015-03-31 11:11 EDT</td>
<td>Investorplace.com</td>
<td>Why You Shouldn’t Buy Alphabet Inc (GOOG) Stock Now</td>
<td></td>
</tr>
</tbody>
</table>

Profit Confidential
Published: November 3, 2016

Why Google Stock Is Loving the Smartphone Market

Alphabet Inc [NASDAQ:GOOGL] and Google stock may be ready to make a huge splash in the phone market as a new report shows “Android” phone sales dominating globally.

88% of the 370 million new smartphones shipped worldwide were running the Android operating system, according to a new report from Strategy Analytics. With Apple Inc’s [NASDAQ:AAPL]’iOS” platform and Android accounting for 87.3% of the worldwide smartphone market share, Google continually looks to place its new smartphone offering, “Pixel.” In opposition to Apple’s “iPhone.”

News Page

MotiveWave™ Console (google)

Time Frame: All
<table>
<thead>
<tr>
<th>Symbol</th>
<th>Released</th>
<th>Time</th>
<th>Source</th>
<th>Headline</th>
</tr>
</thead>
<tbody>
<tr>
<td>GOOG</td>
<td>2016-11-06 07:03 EDT</td>
<td>Profit Confidential</td>
<td>Goog Stock: New Report Is Great News For Alphabet Inc</td>
<td></td>
</tr>
<tr>
<td>GOOGL</td>
<td>2016-04-05 06:28 EDT</td>
<td>Profit Confidential</td>
<td>Alphabet Inc: This GOOG Stock Trend Line is all that Matters</td>
<td></td>
</tr>
<tr>
<td>GOOG</td>
<td>2015-03-31 11:11 EDT</td>
<td>Investorplace.com</td>
<td>Why You Shouldn’t Buy Alphabet Inc (GOOG) Stock Now</td>
<td></td>
</tr>
</tbody>
</table>

Profit Confidential
Published: November 3, 2016

Why Google Stock Is Loving the Smartphone Market

Alphabet Inc [NASDAQ:GOOGL] and Google stock may be ready to make a huge splash in the phone market as a new report shows “Android” phone sales dominating globally.

88% of the 370 million new smartphones shipped worldwide were running the Android operating system, according to a new report from Strategy Analytics. With Apple Inc’s [NASDAQ:AAPL]’iOS” platform and Android accounting for 87.3% of the worldwide smartphone market share, Google continually looks to place its new smartphone offering, “Pixel.” In opposition to Apple’s “iPhone.”
2.1 Preferences

The Preferences Dialog (choose Configure -> Preferences from the Console menu bar) provides a centralized location for configuring MotiveWave™. This dialog contains many configuration panels organized under tabs (and sub tabs).

Feel free to explore the configuration options within MotiveWave™ by looking at the tabs and sub tabs available in this dialog. More detail on specific configuration options can be found in other parts of this document.
2.2 Workspaces

Connections to Brokers and Data Services are managed through workspaces. Each workspace is a separate instance of MotiveWave™ and contains its own local database. All data, settings and analyses are separate between each workspace (with the exception of themes and historical data).

Workspaces can be managed from the Console or from the startup screen (click on the Options drop down and select Workspaces).

The Manage Workspaces dialog enables you to create new workspaces or to edit/modify existing workspaces. The order in which they appear in the startup workspace drop down can also be modified from this dialog. Click on the New Workspace button to create a new workspace.
2.2.1 Professional/Ultimate Editions

Starting with version 4.0 the Professional and Ultimate editions allow multiple broker and/or data service connections within a single workspace.
From the connection dialog (see below) you can choose the broker or data service that you want to add to the workspace. Connection information will depend on the broker/data service that you choose.

The following dialog shows an example of a workspace with three connections (TradeStation, OANDA and TD Ameritrade).
2.2.2 Single Broker Editions

For the other editions of MotiveWave (Charts, Charts Plus, Trade and Strategy) only a single connection to a broker or data service is allowed within a workspace. The following diagram illustrates the create workspace dialog for these editions. Simply choose a name for the workspace and choose the connection type from the service drop down.

![Create Workspace Single Broker Editions](image)

The workspace name uniquely identifies a workspace. All information related to the workspace (configuration, market data, analysis files etc.) are stored in a local database.

The name uniquely identifies the name of the Connection within the workspace. Typically the name is the same as the name of the Service.

### Select Broker/Data Service

The following diagram illustrates the page area and some of the available options:

![Page Area](image)

2.3 Changing the Default Layout

The console layout is highly configurable. All pages can have their layouts modified and pages can be added or removed. The following screen shot illustrates the page area and some of the available options:
2.3.1 Creating a new page

To add a page to the console, click on the New Page button (see above). The New Page dialog will appear (see below). You will need to specify a name for your page. This name is displayed on the page tab when it is added to the console.

There are many different layouts available for your page. Just choose the one that most closely matches what you want to have on the page. Several categories are available in the tabs at the top of the dialog. The icon matching the category will be displayed on the page tab that you are creating (making it easier to identify).

![New Page Dialog]

2.3.2 Modifying a Page

You can change the name of a page and optionally its layout. To modify the current page, click on the Edit Page button on the right hand side of the page area.

![Edit Page]

This will open the Edit Page dialog where you can change the name of the page and optionally select a new layout for the page.
At the bottom of the **Edit Page** dialog you will see a button called **Reset Layout**. This button can be used to reset the console layout to the default. This will reset all of the pages including their layouts to be the same as when you first created the workspace (see **Default Console Layout** screen shot).

---

**2.3.3 Changing the Page Order**

If you would like to change the order of the pages, simply click and drag the page tab to the desired location:

---

**2.3.4 Resizing Panels**

The size of the panels displayed in a page can be resized by clicking and dragging the area between each panel. Notice that the mouse cursor will change when you hover over these areas. The following screen shot illustrates changing the vertical space between the chart area and watch list area in the **Home** page:
### 2.3.5 Adding New Panel Tabs

New panel tabs can be added to each panel area in the active page. Simply click on the **New Tab** button to the right of the existing tabs. The follow screen shots show the sequence to add a new chart to the main panel of the **Home** page. In this example, three charts are stacked on top of each other with the active chart showing with the highlighted tab (in white).
2.3.6 Creating a Custom Layout

MotiveWave™ includes a number of built-in page layouts which are available when you create or edit the page. You can organize the panels in the page however you like by left clicking and dragging the tabs around. As you drag the tab, you will see a highlighted blue area where the panel will be created when you release the mouse button. This feature provides you the flexibility to create any layout with any number of panels. The following screen shot illustrates moving the chart tab that we created in the previous section (MSFT symbol) and creating a new panel area by horizontally dividing the existing panel into two.
2.4 Changing the Look and Feel

MotiveWave™ provides several options for changing the look and feel of the window decorations, docking framework, table colors and chart colors. Use the Preferences dialog to change these attributes (as well as many others). This dialog can be opened by pressing the Preferences button at bottom right of the console window or by choosing Configure -> Preferences from the top menu bar.

If you would like to modify the preferences for the docking framework, click on the General tab then on the Dock sub tab. Several options are available from this panel (see below):
The Themes tab provides several options for changing the look and feel of the window decorations as well as the colors for the chart, tables and buy/sell boxes. Custom Chart and Bar themes can be defined under the corresponding tabs of this section:

The following screen shot shows an example of some theme changes:
Fonts and icon sizes can be changed from the **Fonts** panel. Select the **General Font/Icon Size** option to adjust the overall size of the icons and fonts for the windows and dialogs. This option can be particularly useful on a high resolution screen.

Fonts can also be adjusted for the charts on the **Chart Fonts** tab:
2.5 Instruments

Stocks, FOREX pairs, futures contracts, indices etc are generically referred to as Instruments in MotiveWave™. The available instruments will depend on the broker or data service that you chose for the workspace. When you initially create a workspace in MotiveWave™ a default set of instruments will be populated in the local database. Additional instruments can be added by searching for them or defining them.

All instruments can be centrally managed from the Manage Instruments dialog available from the Console (Configure -> Instruments from the top menu bar).
The Manage Instruments dialog displays all of the instruments that are defined in the local database. You can filter the list by typing in a symbol (or partial symbol) or choosing a specific instrument type or exchange.

Additional instruments can be added to the local database by either clicking the Search, Import or Define buttons (Note: the Define and Import buttons are not available for all brokers/data services).

The Search button will utilize the broker/data service’s search capabilities to discover new instruments that you can add to the local database.

### 2.5.1 Importing Instruments

For convenience, the Import button will allow you to import a set of instruments from a CSV (comma separated values) file. This file can be created using a spreadsheet (such as Microsoft Excel) and saving it as a CSV file. For details on the format of the file, see: [http://www.motivewave.com/data/import_instruments.htm](http://www.motivewave.com/data/import_instruments.htm)
2.5.2 Trading Hours

Trading hours define the days and time of day that an Instrument is traded. For most instruments the trading hours may be assigned automatically by MotiveWave™. When you create your workspace, MotiveWave™ will create a default set of Trading Hours. You can create your own trading hours and override the instrument settings. Trading hours can be created/modified from the Preferences dialog (Configure -> Preferences from the Console menu bar, click on General then on Trading Hours).

The Trading Hours dialog will appear when you click the add button (‘+’ icon) above. If an exchange is chosen, then the hours defined in this dialog will be used as the default trading hours for instruments on that exchange.
The Trading Hours for an instrument can be assigned from the Advanced tab of the Instrument dialog. This dialog can be accessed from the Manage Instruments dialog (Configure -> Instruments from the Console menu bar) or from the context menu of a chart (right click on a chart and choose Edit Instrument).
2.6 Watch Lists

Watch Lists provide a convenient way to organize a related set of instruments together in one location. MotiveWave™ will create a default set of Watch Lists when you first create your workspace.

There are two ways to view a Watch List:

1. **Table View** – In this tabular view, each row displays an instrument. The table view will have a default set of columns, but these can be configured by the user to show or hide any of the available instrument values. Optionally, you can sort this table view by any of the columns in ascending or descending order.

2. **Buy/Sell View** – This view shows a Buy/Sell box for each instrument. The current Best Bid and Best Ask values are shown along with the last price, last time, daily high/low and spread. Market orders can be placed directly by clicking on the Buy or Sell areas.

The following screen shot shows the default set of watch lists displayed on the Home page.
2.6.1 Watch List Tool Bar

Several features are available from the tool bar in the top right area of the watch list panel. These buttons are as follows:

1. **Link With Chart** – If this button is on (shaded background), clicking on a row in the watch list will set the instrument for the active chart on this page.
2. **Table/Buy Sell View** – Toggles the view of the watch list between the table view and the Buy/Sell boxes view
3. **Search/Add Instrument** – Launches the search dialog to search for an instrument and add it to the watch list.
4. **Import Instruments** – Click this to import a set of instruments from a CSV file (not available on all workspaces)
5. **Edit Watch List** – Edits the watch lists properties
6. **Open in Window** – Opens this watch list in a separate window
7. **Maximize** – Maximizes the watch list panel to use all of the available space on the page

The following screen shot shows these buttons in the tool bar:

![Watch List Tool Bar](image)

2.6.2 Sorting Options

The table view of the watch list can be either sorted or unsorted. This mode can be toggled by clicking on the column headers within the table view. Clicking a column header once sorts it by ascending order. Clicking a second time will sort in descending order. A third click will make the table unsorted returning it to its natural order.

2.6.2.1 Unsorted View

In the unsorted view, you can arrange the instruments in the list by clicking and dragging them to the desired location. Alternatively, right click on a row and choose **Move Up / Move Down** to adjust their locations.
2.6.3 Buy/Sell Boxes

A Buy/Sell box shows the current Best Bid and Best Ask prices for an instrument and makes it easy to quickly place a market order to buy or sell the instrument. The following diagram shows the elements of a Buy/Sell box:

The colors of the box will change as the prices change. If the price goes up the label will flash blue (or green depending on preferences). If the price goes down, the label will flash red.

You can modify the preferences for the Buy/Sell boxes from the Preferences dialog (Configure -> Preferences from the Console menu bar).
2.6.4 Create Watch List

Choose **File -> New -> New Watch List** from the Console menu bar to create a new watch list.

On the first page of the **New Watch List** wizard, you will be asked for the name of the **Watch List**. This name will be displayed on the panel tab.
On the next page of the wizard, you will be asked to specify the columns. If you would like to add one or more columns to the list, select them from the **Available Columns** list (hint: use the **Ctrl** key or **Cmd** key on OSX to select multiple rows) and press the ‘>’ button to move them to the **Selected Columns** list. If you would like to remove one or more columns, select them from the **Selected Columns** list and press the ‘<’ button.

The last step is to choose the set of instruments that will be displayed in the **Watch List**. Type the name of the symbol in the **Choose Symbol** field and press **Enter** to add it to the list. Alternatively, select a
name from the drop down. You can also search for a particular symbol by clicking the Search/Add button. If supported by your broker/data service you can import a set of symbols by clicking on the import button (see below).

2.6.5 Edit Watch List

Click on the Edit Watch List button (pencil icon) on the Watch List tool bar to open the Edit Watch List dialog. From this dialog you can change the name, available columns or the instruments.
For convenience, columns can be modified directly from the Watch List. Click and drag a column header to change the order. On the right hand side of the column header, there is a button that can be used to show or hide columns.

### 2.7 Quote Sheets

A Quote Sheet is a special version of a Watch List that can be divided into sub groups. When creating Watch List, make sure to select the Quote Sheet option on the first page of the Watch List wizard.

On the first page of the Watch List Wizard, you will be asked to enter a name for the Quote Sheet. Similar to the Watch List, this will be displayed in the tab of the Quote Sheet Panel. Make sure to check the “Quote Sheet” option below the Name entry field.
Choosing the columns for the Quote Sheet is the same as you would for a Watch List. Select the column(s) you would like to add from the Available Columns list and use the ‘>’ button to add them to the Selected Columns list.

**Quote Sheets** organize instruments into groups. Click on the **New Group** button to add one or more groups to the **Quote Sheet**. You can add instruments to each group by selecting the group from the **Group** drop down and then using the **Add Instrument/Search Instrument** buttons (see below).
The following screen shot shows a sample Quote Sheet. Noticed that there are groups in the Quote Sheet table that divide the instruments into different categories. Optionally each group can have different colors for the dividers.
2.8 Backup/Restore

The Backup/Restore feature enables you to export settings, analyses, instruments, watch lists, scans and open windows/positions to a single backup file. This backup file can be archived to be restored later in case something happens to your computer. Alternatively, you can use this feature to transfer your workspace to another computer.

2.8.1 Creating a Backup

Choose File -> Backup from the Console menu bar to create a backup file. When you choose this option, you will see the Backup Workspace dialog.

When you click the Create button, a backup file will be created on your computer desktop. This backup file will be named <Workspace Name> <Date>.zip (where <Workspace Name> is the name of your workspace and <Date> is the current date/time). If you would like to change the name and location, click on the Browse button.

You can store this file in a safe place (such as Drop Box or Google Drive) or move it to another computer to restore it into an existing workspace.

2.8.2 Restore From Backup

Choose File -> Restore from the Console menu bar to restore from a previously created backup.
Click on the **Browse** button and locate the backup file that you created previously. The options available for restore are as follows:

1. **Restore Console/Windows** – Restores console layout/pages and open windows from the backup file.
2. **Restore Preferences** – These are the settings from the Preferences dialog.
3. **Restore Watch Lists** – Watch Lists and Quote Sheets
4. **Restore Scans** – Scan criteria saved from the backup
6. **Delete Existing Analyses** – If you check this option, all of the existing analyses in the workspace will be deleted before importing the analyses from the backup.

Click the **Restore** button to begin the restore process. You will see a progress indicator that reports the status of the restore. Depending on your computer and the size of the backup, this could take up to a minute or two to complete.

**Note:** The file format for the backup has changed in version 5 (compressed zip format).

### 2.8.2.1 Restoring to a Different Workspace Service

In the typical case, the workspace service (ie broker or data service) will match the service from the backup. You can restore from a backup that was created with a different service, but you may encounter some issues. Each service has a different naming symbology for the instruments that they support and the target service may not support all of the instruments that are in the backup.

MotiveWave™ will attempt to map the symbols from the backup service to the target service. However, you may find that some analyses are missing in the new workspace if MotiveWave™ could not find a mapping.

### 2.9 Repository

MotiveWave™ maintains a local database for each workspace. This database contains the following information:

1. **Instruments/Exchanges/Trading Hours/Order Presets**
2. **Preferences/Keyboard Shortcuts**
3. **Watch Lists/Quote Sheets**
4. **Historical News**
5. Analysis
6. Alerts
7. Chart Templates
8. Scan Criteria
9. Strategy Analyses
10. Historical Trades
11. **Historical Data** – Historical data is stored in 1, 5, 30 and daily bars. This is used to reduce load on the servers and is also available in *Offline* mode.

Optionally, data that is normally stored in the local database can be stored in the file system. This can be very useful if you want to synchronize this data (using Google Drive or Drop Box) with other computers or use as an alternative way to create backups.

Choose *Configure -> Repository* from the Console menu bar to access the Repository settings.

Uncheck the **Use Local Database** option to store information in the File System instead of the database. You will need to choose the root directory for this information by clicking the *Browse* button. If you
would like to share this data using Google Drive or Drop Box, make sure to choose a location inside the shared folder.

Optionally you can choose to store the following types of information by checking the boxes below:

1. **Include Preferences** – this is the settings in the Preferences dialog and other configured settings.
2. **Include Watch Lists** – watch lists and quote sheets
3. **Include Chart Templates** – any study templates that you have setup in your system
4. **Include Windows & Layouts** – open window information and locations as well as the Console layout
5. **Include Scans** – scan criteria
6. **Include Global Alerts** – this applies to price alerts.

### 2.9.1 Sharing using Google Drive or Drop Box

Storing data in the File System provides the flexibility to share this information with other computers using utilities such as Google Drive or Drop Box. Note: this feature is not limited to these two services. Any cloud based service that interacts with your local file system should work just as well.

For more information on these services, see their websites:

1. [https://www.dropbox.com/](https://www.dropbox.com/)
2. [https://drive.google.com/](https://drive.google.com/)

**Note:** some issues have been found with Google Drive. These issues are related to the behavior of Google Drive when sharing files. For more information see: [http://www.techrepublic.com/blog/google-in-the-enterprise/steering-around-the-potholes-with-google-drive/](http://www.techrepublic.com/blog/google-in-the-enterprise/steering-around-the-potholes-with-google-drive/)

### 2.9.2 Folder Structure

If you look at the root folder for the repository you will see two folders:

1. **analysis** – contains analysis files. This directory contains several sub folders that organize analysis by instrument type and instrument symbol.
2. **config** – contains configuration files

The following diagram shows an example repository structure for an FXCM workspace.
### 2.9.3 Analysis Sources

Analysis sources provide a way to share specific analyses or to access analyses from other MotiveWave™ users. Analysis sources are defined by a folder that exists in your local file system. You would need to use a service such as Google Drive or Drop Box to perform the sharing and synchronization.

Analysis sources are defined in the Repository Dialog (Configure -> Repository from the Console menu bar)
Click on the Add button to define an analysis source. You can have multiple analysis sources. The Override Repository option is important if there are naming conflicts between your local repository and the analysis sources.

For example if you created an analysis called “Wave 3 Intraday” for the EUR/USD pair and one of the analysis sources also has an analysis called “Wave 3 Intraday” for EUR/USD, MotiveWave™ will need to determine which one to display. If Override Repository is checked, it will display the one from the analysis source (instead of the local repository).

The following dialog will appear when you click the Add button. Each analysis source will require a name. This name can be anything you like, but should reflect the source of the analyses. In the example below, we chose the name “Trading Analysis” (this is one of our partners). Choose a directory (folder) for the source by clicking on the Browse button. (Note: this will be a folder that is synchronized using Google Drive/Drop Box).

The Read Only attribute indicates if you are going to be modifying the analyses or just viewing them. Uncheck this option if you are intending to publish analyses to this source.
2.9.3.1 Publishing Analyses

If you are planning to share your analyses with other users, then you would create an analysis source and uncheck the Read Only attribute. Analyses that exist in your repository are not automatically shared; you will need to explicitly publish each analysis to this new source.

If you would like to publish an analysis to an analysis source, choose File -> Save To -> <Analysis Source Name> (where <Analysis Source Name> is the name you chose in the Add Analysis Source Dialog) from the chart menu bar (Note: it is File -> Chart -> Save To -> <Analysis Source Name> from the Console).

This action will save this analysis (make a copy) to a sub folder in the analysis source folder that you defined earlier.

The file synchronization software that you setup (ie Drop Box etc) will take care of synchronizing that file with the folders of all your users.

In the following example, we have created an analysis source called My Group. The Read Only attribute has been unchecked to tell MotiveWave™ that it can publish analyses to this location. This analysis source will now be available in the Save To menu (see below).

2.10 Email Configuration

MotiveWave™ may be configured to send out email messages as part of alerts or signals generated by studies. You will need to configure the SMTP (Simple Mail Transfer Protocol) settings in the Preferences dialog to enable this feature. These settings will be found under the Email tab. Choose Configure -> Preferences from the Console menu bar to display the Preferences dialog.
If you are using a corporate email address, you will need to contact your network administrator to get the specific SMTP settings.

Settings for public email addresses can be found online, just do a web search. Here are some useful links for some common email providers:

### 2.10.1 Gmail
Gmail settings can be found here: [http://email.about.com/od/accessinggmail/f/Gmail_SMTP_Settings.htm](http://email.about.com/od/accessinggmail/f/Gmail_SMTP_Settings.htm)

For some user accounts you may need to create an application specific password in order for this to work. For more information see: [https://support.google.com/mail/answer/1173270?hl=en](https://support.google.com/mail/answer/1173270?hl=en)

### 2.10.2 Yahoo Mail
Yahoo mail settings can be found here: [http://email.about.com/od/accessingyahoomail/f/Yahoo_Mail_SMTP_Settings.htm](http://email.about.com/od/accessingyahoomail/f/Yahoo_Mail_SMTP_Settings.htm)

Similar to Gmail you may need to setup an application specific password if you have to bypass the second sign-in verification: [https://help.yahoo.com/kb/yahoo-account/SLN5013.html?impressions=true](https://help.yahoo.com/kb/yahoo-account/SLN5013.html?impressions=true)

### 2.10.3 Windows Live / Hotmail
The following link explains the Hotmail SMTP settings: [http://email.about.com/od/accessinghotmail/f/Windows_Live_Hotmail_SMTP_Settings.htm](http://email.about.com/od/accessinghotmail/f/Windows_Live_Hotmail_SMTP_Settings.htm)
There is also a two-step verification process for Hotmail as well. For more information see:
3 Charts

MotiveWave™ has perhaps some of the most advanced charting capabilities of any charting application available. In this section we will be exploring some of the basics of working with charts in MotiveWave™.

You can work with charts within the Console window or you can open separate chart windows to work with charts independently. The simplest way to open a chart window is to press the Open Chart Window button from the top right section of a chart panel. Alternatively, choose File -> New -> New Chart Window from the top menu bar.

This action will open a chart window similar to the one in the screen shot below. Regardless of whether you choose to work with charts in the console or separate chart windows, the features described in this section are the same.
3.1 Settings

3.1.1 Default Chart Settings and Options

Default chart settings can be set from the Preferences dialog (Configure -> Preferences from the Console menu bar). You will find the settings for charts in the tabs underneath the Chart tab.

![Global Chart Settings](image)

The following are options that are available from the Chart Settings tab:

1. **Default Tool** – This is the default tool to use on a chart.
2. **Revert to Default Tool** – When completing an action with the selected tool, the chart will automatically switch back to the default tool (see above)
3. **Bar Type** – The default type of bar to display when opening a chart
4. **Bar Scheme** – Determines the color scheme for the bars. Normal displays bar color based on if the close is higher/lower than the open value. Available Bar Schemes include:
   a. **Normal** – Displays a different color if the bar closes higher than open verses lower than open
   b. **Inside/Outside** – Colors change if bar closes higher/lower than open, if the bar has a lower high/higher low than previous bar (inside) and if the bar has a higher high/lower low than the previous bar (outside)
   c. **Day Of Week** – Bar color changes based on the day of the week
   d. **Alternate Day** – Bar color alternates each day
   e. **Alternate Hour** – Bar Color alternates each hour
5. **Bar Size** – default bar size when opening a new chart
6. **Bar Thickness** – Default thickness for the bar outline (default 1 pixel)
7. **Axis Style** – Style of the price and time axis
8. **Shade** – draws a shaded area at time or price intervals on the
9. **Shift + Click** – Object to draw when the user holds down on the Shift Key and clicks the left mouse button on the chart.

10. **Ctrl + Click** – Object to draw when the user holds down on the Ctrl Key and clicks the left mouse button on the chart.

11. **Shift + Alt + Click** – Object to draw when the user holds down on the Ctrl and Alt Keys and clicks the left mouse button on the chart.

12. **Line Method** – Calculation method for calculating the lines on a wedge (Time/Price or Angle)

13. **Fill Area** – If true, the area of a wedge will be filled

14. **Fill Alpha** – Alpha value for the fill color

15. **Max Linear Bars** – Maximum number of linear bars to load when opening a chart

16. **Max Non Linear Bars** – Maximum number of non-linear bars (ie Range, Renko etc) to load when opening a chart

17. **Minimum Bars** – Minimum number of bars to load when opening a chart.

18. **Bar Width (pixels)** – Default spacing for the price bars

19. **Price Axis Spacing** – Default spacing between the numbers that are displayed on the price axis

20. **Time Axis Spacing** – Default spacing between the labels that are displayed on the time axis

21. **Top Inset (pixels)** – Default spacing to add to the top of the price plot when auto scale is enabled

22. **Bottom Inset (pixels)** – Default spacing to add to the bottom of the price plot when auto scale is enabled

23. **Display Bars** – percentage of bars to display when first opening a chart (ie fill 90% of the chart area)

24. **Study Height (pixels)** – Default height for study plots

25. **Study Layout** – Layout preference for the study labels displayed in the legend area (horizontal or vertical)

26. **Time Zone** – Default time zone for the chart.

27. **Calendar Days** – If enabled, space will be preserved for non-trading days when displaying daily bars (normally this space is removed)

Additional chart options can be found under the **Options** tab of the **Chart** section in the **Preferences** dialog.
<table>
<thead>
<tr>
<th>Global Chart Options</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>1. Show Extended Data</strong> – If true, after hours data is show by default when opening a chart</td>
</tr>
<tr>
<td><strong>2. Show Instrument Title</strong> – Displays the title of the instrument in the top left corner of the chart</td>
</tr>
<tr>
<td><strong>3. Snap Open/Close</strong> – If this is enabled, the mouse tools will automatically snap to open and closing points on the price bars</td>
</tr>
<tr>
<td><strong>4. Show Components Panel</strong> – Displays the components panel by default when opening a new chart.</td>
</tr>
<tr>
<td><strong>5. Show DOM Panel</strong> – Displays the DOM (Depth of Market) panel by default when opening a new chart</td>
</tr>
<tr>
<td><strong>6. Show Grid</strong> – Displays horizontal and vertical lines on the chart</td>
</tr>
<tr>
<td><strong>7. Show Major Times</strong> – Show vertical dashed lines for major time on the chart</td>
</tr>
<tr>
<td><strong>8. Show Chart Buttons</strong> – Enables the display buttons on the chart for adjusting the vertical space and bar width. This also applies to the remove study button on study plots.</td>
</tr>
<tr>
<td><strong>9. Show P/L Ladder</strong> – Displays the profit/loss ladder on the chart.</td>
</tr>
<tr>
<td><strong>10. Show Exchange</strong> – Toggles the display of the exchange as part of the title on the chart</td>
</tr>
<tr>
<td><strong>11. Show Symbol</strong> – Displays the instrument symbol on the chart.</td>
</tr>
<tr>
<td><strong>12. Show Bar Size</strong> – Displays the current bar size on the chart</td>
</tr>
<tr>
<td><strong>13. Show Cross Hair</strong> – Toggles the default display of the cross hair feature for the mouse cursor</td>
</tr>
<tr>
<td><strong>14. Global Cross Hair</strong> – If enabled, the cross hair (where enabled) will be updated across multiple charts that display the same instrument</td>
</tr>
<tr>
<td><strong>15. Double Cross Hair</strong> – Displays two vertical lines encompassing the bar where the cursor is currently (instead of a single vertical line)</td>
</tr>
<tr>
<td><strong>16. Solid Cross Hair</strong> – Displays a solid line instead of a dashed line for the cross hair</td>
</tr>
<tr>
<td><strong>17. Auto Scale</strong> – Default scale setting when opening a new chart</td>
</tr>
<tr>
<td><strong>18. Auto Scale Price Only</strong> – If enabled, only the price action will be included in the auto scaling of the chart (components are excluded)</td>
</tr>
<tr>
<td><strong>19. Semi-Log Scale</strong> – Displays a chart using semi-log scale by default.</td>
</tr>
</tbody>
</table>
21. **Lock Scroll** – Default lock scroll state (see Lock Scroll feature)
22. **Lock Studies** – Default Lock Studies state (see Lock Studies feature)
23. **Show Info on Select** – Turns on the Show Info feature when selecting a component
24. **Show Info** – Enables the show info feature when creating a new component
25. **Show Range Outline** – Turns on the range outline on the latest bar for Range/Renko bars
26. **Show Middle Line** – Turns on the display of the middle line for channel components
27. **Show Menu Bar** – Turns on the display of the menu bar for windows
28. **Show Tool Bar** – Turns on the display of the tool bar for windows
29. **Show Status Bar** – Turns on the display of the status bar at the bottom of the windows
30. **Confirm on Close** – If enabled will display a warning message when closing a chart window
31. **Link Minimize/Restore** – If enabled, for linked chart windows all windows in the group will be minimized when one of them is minimized. Likewise when one of them is restored, all windows in the group will be restored
32. **Expand Status Bar Link** – Expanded mode for the color link control in the status bar
33. **Show Bar Size Selector** – Toggles the default display of the Bar Size Selector on charts
34. **Show Bird’s Eye View** – Toggles the default display of the Bird’s Eye View when opening a chart
35. **Show Bird’s Eye Lines** – Display of the vertical lines on the Bird’s Eye plot
36. **Resolve Trend Lines** – If enabled, MotiveWave™ will attempt to load enough data to properly display all trend lines on a chart. By default it will estimate where the starting point of a trend line is based on the available data. This option will force the loading of data all the way back to the beginning of trend lines to improve the accuracy of the plot. **Warning:** this option can cause a lot of data to be loaded from your broker or data service. It is recommended that you leave this option off and turn it on where desired from the Chart Settings dialog (see next section).
37. **Group Studies** – If enabled, study plots will be grouped together at the bottom of the chart in a stacked panel.
38. **Show Study Labels** – Enables the display of study labels in the legend
39. **Study Bar Updates** – Toggles the live updating of studies from level 1 data verses calculating the most recent study values on the close of a bar.
40. **Show Values in Legend** – If enabled, current study values will be displayed next to the study label in the study legend
41. **Simple Study Title** – Simplified display of the title in the legend area
42. **Overlay Volume** – Displays the volume information as an overlay on the chart instead of a separate plot.
43. **Draw Candle Outline** – Draws the outline of the candle rectangle.

### 3.1.2 Chart Specific Settings

Chart settings that apply to the selected chart only can be accessed by right clicking on the chart and choosing Chart Settings (you can also double click on the chart). The settings configured here can be saved as default settings by clicking on the Save Defaults button. Descriptions of items below can be found in the preceding sections.
3.2 Price Indicators

Price indicators display current price, high low (etc) on the price axis of a chart. By default, MotiveWave™ will display (where available) the **Last Price, Best Bid, Best Ask, Daily High** and **Daily Low**. Other indicators may be (optionally) displayed in the vertical axis from overlays such as a Moving Average. If you would like to show a vertical line that moves with the indicator just double click on it (this will toggle the display of the line).
You may change the price indicators that are displayed from the Preferences dialog. Click on Chart, then on Indicators.

3.3 Chart Spacing

There are several options for adjusting the horizontal and vertical spacing on the chart. The simplest way is to use the mouse to drag either the time axis (horizontal spacing) or the price axis (vertical spacing). Note: in order to adjust the vertical spacing, you need to click and drag the space between the price labels and the chart area (see below)
3.4 Bar Sizes

Bar sizes are useful for changing the resolution of a chart based on time, price or volume movements. MotiveWave™ supports several different types of bars:

1. **Linear** – time interval based bars (such as 1 minute, 15 minute, 1 day, 2 week etc)
2. **Range** – bars are based on price movements of a specific price range
3. **Renko/Hybrid Renko** – these are special price range based bars
4. **Tick** – these bars are based on a specific number of price ticks (or trades)
5. **Volume** – each of these bars will have a fixed trading volume
6. **Point & Figure**

There are several ways to change the bar size and type. Perhaps the most convenient way is to use the **Bar Size Selector** at the bottom of the chart. Alternatively, you can use the bar size drop down from the tool bar or right click on the chart and select the bar size from the context menu.
3.4.1 Custom Bar Sizes

MotiveWave™ comes with a default set of bar sizes, but you can create your own bar sizes from the Preferences Dialog (Configure -> Preferences from the Console menu bar). You can create second based bars provided you have access to historical tick data.
3.4.2 Bar Size Selector

The Bar Size Selector is a convenient way to access common bar sizes by simply clicking on one of the tabs at the bottom of the chart. The Bar Size Selector is visible by default on all charts. If you would like to hide this, choose View -> Display -> Bar Size Selector from the top menu bar to toggle its visibility. (Note: the default behavior can be modified in the Preferences dialog, click on Chart the on Options, see Show Bar Size Selector option).

You can configure the tabs available in the Bar Size Selector by right clicking on one of the tabs and choosing Configure. You can put any type of bar size in the selector. For example, you could have Range(3) or Constant Volume(500).

The Bar Size Selector also has some buttons on the right hand side (configurable in Preferences). These can be convenient for the following (in order from left to right):

1. Toggle Semi-Log Scale – Toggles semi-log scaling
2. Choose Study Template – Allows you to choose a study template
3. Toggle Birds Eye View – Toggles the display of the Birds Eye View
4. Display Time Frame – Choose a specific time frame to display on the chart (ie 2 week, 1 day etc)
5. Go To Date – Go to a specific date in history
3.5 Importing Data

Historical data may be imported into MotiveWave™ by choosing File -> Import Data from the top menu bar (File -> Chart -> Import Data from the Console menu bar). Two types of data formats are supported:

1. **CSV** – Comma Separated Values. This is a very common format for many historical data services. The format of the data file will be automatically detected when specifying files of this type.

2. **MetaStock™ Database** – MetaStock™ Database files containing 1 or more instruments may be imported into MotiveWave’s historical database.

This dialog has the following elements:

1. **Data Files** – Specify one or more data files by clicking on the Add button to left of the Data Files list.

2. **Time Zone** – Choose the time zone for the input file. This is important for resolving the data/time values for each historical price bar in the input file.

3. **Exchange** – Optionally Choose the Exchange for the instrument(s) in the input file(s).

4. **Trading Hours** – If a value is chosen for Trading Hours, it will be assigned to the instrument when it is created from this dialog.

5. **Adjust for Stock Splits** – If the file does not contain split adjusted values, this will detect and adjust historical prices for splits.

6. **Automatically Create Instrument (Do Not Prompt)** – If the instrument does not already exist in the local database, it will be automatically created if this is checked.

7. **Replace Existing Data** – Replaces data that is already in the local historical database.

8. **Monitor Input File For Changes** – If checked, MotiveWave™ will monitor the timestamp on the input file to see if it changes in the future. If it does change, the new data will be automatically loaded into MotiveWave™ when a chart is loaded.
3.6 Exporting Data

Historical data may be exported from MotiveWave™ in several different formats. Choose File -> Export Data from the top menu bar (File -> Chart -> Export Data from the Console menu bar). This dialog has the following elements:

1. **Symbol** – Choose the instrument that you would like to export. By default this is the instrument from the chart where the dialog was launched.
2. **Bar Size** – Choose the Bar Size for the historical data
3. **Bar Count** – Number of Bars to Export. Choose All Available to export all available data in the historical database
4. **Regular Trading Hours (RTH) Data** – Check this to only include bars that are part of the regular trading session
5. **Data File** – Click on the Browse button to the right to choose the data file where the data will be saved.
6. **Format** – Choose the Export Format
   a. CSV – yyyyMMdd HHmmss,O,H,L,C,V
   b. CSV – dd/MM/yyyy HH:mm:ss,O,H,L,C,V
   c. Ninja Trader – Start Of Bar Time
   d. Ninja Trader – End Of Bar Time
3.7 Bird’s Eye View

The **Bird’s Eye View** provides a convenient way to view the larger picture of the available historical data. Choose *View -> Display -> Bird’s Eye View* from the top menu bar to toggle the display of this feature.

The **Bird’s Eye View** is displayed at the bottom of the chart. The highlighted area (transparent yellow area) illustrates the data that is currently visible in the chart. You can click and drag this area to the left/right to move the visible area. The width of the highlighted area depends on the bar width for the chart. If you would like to change the width, click and drag the time axis.

3.8 Cursor Data

**Cursor Data** refers to the data points and their values at the current position of the mouse cursor. There are several different ways to view cursor data.

3.8.1 Cursor Data Window

The **Cursor Data Window** is a separate window that displays data at the current mouse location. This window works across all charts. This window may be opened by choosing *View -> Display -> Cursor Data*
Window from the top menu bar. For convenience this window is always displayed on top of other windows.

3.8.2 Cursor Data Panel

The Cursor Data Panel is essentially the same as the Cursor Data Window except that it is a panel inside of the chart. This panel only works for the enclosing chart. To open this panel, choose View -> Cursor Data from the top menu bar.
3.8.3 Bar Status
Data on the selected price bar can be found in the status bar at the bottom of the window. This reflects the price bar at the position of the mouse cursor.

3.8.4 Hover Popup
A popup will be displayed with information about the price bar if you place the mouse cursor over a price bar and leave it there for about 2 seconds.

3.8.5 Cross Hair
The cross hair feature draws thin horizontal and vertical lines at the current mouse cursor location to indicate the vertical axis and time axis values.
There are several configuration options for the cross hair. These can be found under the Chart -> Options tab of the Preferences dialog (Configure -> Preferences from the Console menu bar).
3.8.5.1 Global Cross Hair

The Global Cross Hair provides a convenient way to locate the mouse cursor position between several different charts that are displaying the same instrument. This option can be enabled in the Preferences dialog (see previous section). In the following screen shot you will notice that the current location of the mouse cursor in one chart adjusts the cross hair location in the other charts that show the same instrument.

3.9 Time & Sales

The Time & Sales panel shows historical ticks for the selected instrument. The data and columns available in this panel will depend on the broker or data service that you have chosen. The following example shows the Time & Sales panel for the e-Mini S&P contract:
For convenience, a button is available on the tool bar to toggle the display of this panel. Alternatively choose View -> Display -> Time & Sales Panel from the top menu bar.

### 3.10 Depth Of Market (DOM) Panel

The Depth Of Market (DOM) panel shows a tabular view of the current bid and ask sizes. Choose View -> Display -> DOM Panel from the top menu bar to show or hide this panel on a chart. For convenience a toggle button is also available on the tool bar. For details on how to use the DOM panel see Depth Of Market section.
3.11 Chart Labels

Chart labels display information on the Price Plot of the chart. These labels can appear in any of the 4 corners. The following example shows some chart labels:
You can configure the labels displayed on a chart from the Chart Settings dialog (double click on the chart). You will find the labels under the Labels tab:
Double click on one of the labels in the right hand box (or select and press the edit button, ie pencil icon) to edit the properties of the label (see embedded dialog above). From there you can choose which corner to display the label and adjust the color, font etc. The order in which the labels are displayed is determined using the up/down arrow buttons in the Chart Settings dialog (see above).

### 3.12 News

If supported by your Broker/Data Service, news articles specific to the instrument can be displayed on the chart by showing the **News Headlines** panel. Choose **View -> Display -> News Headlines** from the top menu bar.

If you click on a headline in the news headlines panel, it will display the news article in the internal news viewer by default. If you right click on the headline, you can optionally display the news article in your web browser.

The following screen shot shows an example of displaying a news article in the **News Viewer**:
3.13 Watermark

The Watermark feature in MotiveWave™ enables you to display a semi-transparent label with the instrument’s symbol and/or description. You can also choose the location and font of this label. The watermark can be configured from the Chart Settings dialog, see Watermark tab.

The following screen shot shows the watermark description for Microsoft:
3.14 Scaling

Several different scaling options are available for scaling the price/time range of the price plot. By default the chart price range is automatically scaled from the visible data and components (Auto Scale). The following are the available scaling options:

1. **Auto Scale** – Price range is adjusted according to visible data and visible components (optionally, only the data range can be considered). This option will lock the vertical movement of the chart.
2. **Price Range** – This option keeps the price range constant and enables you to manually move the graph up/down.
3. **Square** – This option will set a fixed number of points per bar width. If the bar width is expanded (or contracted) the price range will be updated to reflect.

Scaling options can be found under the **Scaling** tab of the **Chart Settings** dialog.
3.15 Analyses

MotiveWave™ employs the concept of an Analysis to encapsulate the work that you have done in a chart to analyze price movement. An analysis will contain the following types of information:

1. **Components** – any components that you have added to the chart including: trend lines, Elliott Waves, Gann components, Gartley patterns, commentary etc
2. **Studies** – Any studies that you have added to the chart
3. **Time/Price Guides** – These are guides that you have added to the horizontal or vertical axes.

It is important to understand that an analysis is a separate entity from a chart. A chart is a view or an analysis file. This is an important distinction and is fundamental to the underlying design of MotiveWave™. While this concept may seem a little confusing at first, it has numerous advantages:

1. **View in Multiple Time Frames** – A single analysis can be viewed at multiple time frames simultaneously. You can have several open charts that reference the same analysis and edit them from each chart.
2. **Alternate Analyses** – Each instrument can have any number of analyses. The name of an analysis is scoped to the instrument so it does not have to be unique across symbols.
3. **Saved in Repository** – You can save an analysis and load it later after the chart has been closed
4. **Share with other People** – Analyses can be exported in XML format and shared with your friends. You can also share analyses using the Analysis Sources feature.

The following diagram illustrates the relationship between charts and analyses. Each instrument may have multiple analyses which are saved in the local database (repository). When you open a chart, you are opening an analysis. MotiveWave™ allows you to open an analysis from more than one chart at the same time. Changes made in either chart are synchronized between the two so you do not have to worry about overwriting your modifications.
3.15.1 Creating a New Analysis

The default analysis for any instrument is called the Primary Analysis. Whenever you open a chart for the first time, it will open the Primary Analysis. The net effect of this behavior is that all changes between the open charts for that instrument will be synchronized between them.

If you do not want these changes to be synchronized, you can create one or more Alternate Analyses. There are several ways to do this; perhaps the most convenient is to use the New Analysis button on the tool bar.
The following dialog will appear when you create a new analysis. Enter a name for the analysis. By default, analyses are named *Alternate 1, Alternate 2* etc. You can however choose any name you like for the analysis. A new analysis may be empty (just price bars) or you can base an analysis on an existing analysis by choosing one from the **Based On** drop down.

Once you have created the new analysis, the chart will display a set of tabs at the top where the active tab is named with the new analysis.
3.15.2 Open Existing Analysis

If you want to quickly open an analysis, just click on the small black triangle next to the open button on the tool bar. Alternatively, choose File -> Open/Manage Analyses from the top menu bar (File -> Chart -> Open/Manage Analyses from the Console menu bar).

3.15.3 Manage Analyses

The Manage Analyses dialog allows you to open, export, rename, delete or create new analyses for the given instrument. This dialog can be accessed from the menu bar: File -> Open/Manage Analyses from the top menu bar (File -> Chart -> Open/Manage Analyses from the Console menu bar).

3.15.4 Import/Export Analyses

Import and export are very valuable tools for sharing your analysis with another MotiveWave™ user.

When you export an analysis file, the file will contain all of the information related to your analysis as well as information about the instrument. The exported file will be in JSON format and will have an extension of .mwml (MotiveWave Markup Language).

Choose File -> Export Analysis from the top menu bar (File -> Chart -> Export Analysis from the Console) to open the Export Analysis dialog. By default the analysis file will be saved on your computer desktop in the form <Symbol> – <Analysis Name>.mwml. You may change this name and location if you like. Click on the Save button to export the analysis to the selected file.
Similarly, to import an analysis file, choose File -> Import Analysis from the top menu bar (File -> Chart -> Import Analysis from the Console) to display the Import Analysis dialog. Locate the analysis file, select it and press the Open button. If the chart you are currently using has the same instrument as the imported analysis file, it will be opened in another analysis tab. If the instrument does not match the chart, a message dialog will be displayed indicating that the import was successful and how to open the imported file.
3.16 Components

Many different types of components can be added to a chart as part of your analysis. Examples of components include Trend Lines, Price Labels, Channels, Commentary, Elliott Waves, and Markers. Components can be added to a chart from the Components Panel or by using the Mouse Tools (available from the tool bar).

3.16.1 Components Panel

The Components Panel organizes the available components in MotiveWave™. This panel is displayed on the left hand side of the chart area and is organized into folders. You can hide this panel by clicking on the ‘X’ in the top right corner of the panel. A toggle button is available on the right hand side of the tool bar to show/hide this panel as well. Alternatively, choose View -> Display -> Components from the top menu bar.

3.16.2 Adding a Component

To add a component from the Components Panel, simply click and drag (using the left mouse button) the component onto the chart area (see below). Alternatively, you can double click on a component, or right click and choose Add To -> <Graph> to add it to the center of the chart.
Mouse Tools are available for some of the more common components. In some case these tools can be more convenient than using the Components Panel. These mouse tools can be found under the Tools dropdown on the tool bar. You can customize the tool bar to make certain mouse tools more convenient to access. Short-cut keys are also available to quickly select tools. These keys typically take the form of Ctrl + Shift + <Key> (see tool menu for key combinations, Note: on Mac OS X use Cmd instead of Ctrl.)

The following example shows the usage of the Channel Tool to create a channel. This particular tool requires three clicks to define the channel. Also the channel is drawn as you click the mouse.
3.16.3 Selecting Components

You can select components on a chart by simply clicking on them with the left mouse button. When a component is selected, you will typically see green resize points that indicate areas that you can move to modify the component.

If you want to select multiple components, simply hold down on the Shift key while clicking on other components. The first component selected will have green resize points (primary component) and the other components will display blue resize points (secondary components).
Selecting multiple components can be useful if you want to move them as a group or delete them. Some components such as trend lines have options from the right click menu (right mouse click) that apply to the group. In the following example, you can make two (or more) lines parallel by selecting them and choosing the “Make Lines Parallel” option from the right click menu. (Note: lines will be drawn parallel to the primary component, ie the one selected first):

3.16.4 Deleting a Component
Deleting (removing) a component from a chart is straight forward. Simply click on the component to select it and then press the ‘Delete’ key on the keyboard. Alternatively, right click on it and choose Edit -> Delete.

If you want to delete all components from a chart, choose Edit -> Delete All from the top menu bar.
3.16.5 Component Properties

Components may be modified from the Component Properties dialog and (in many cases) by using the right click menu that is available via right click on a component. You can open the Properties dialog by double clicking on a component or right click and choose Properties.

The following screen shot shows the Component Properties dialog for the Channel component. The options available in this dialog will vary depending on what component you are editing.

3.16.5.1 Formatting

Formatting options such as color, font, line width/style, shading etc can be found under the Format tab of the Properties dialog (double click on the component). For convenience several formatting options are available on the tool bar for changing the component format. These buttons are context sensitive and will apply to the selected component (see below). These buttons will appear inactive (greyed out) if no component is selected.
3.16.6 Working with Trend Lines

Trend lines are an important element of most all forms of market analysis. Several features are built into MotiveWave™ to make working with trend lines easier.

Trend Lines can be created by using the **Line Tool** that is available from the tools drop down.

Creating a trend line requires two left mouse clicks. The first click defines the starting point for the line and the second defines the end point. Once you have created the Trend Line, you can press the Space bar to switch the tool back to the default **Time Drag tool**.
Creating a Trend Line

When a trend line is selected it will display basic information about that trend line (such as the price range and time span). You can adjust the line by moving the end points (green resize points). These points will snap to key locations such as the top or bottom of price bars (hold down on the ‘Alt’ key to disable this feature).

Adjusting a Trend Line

Common angles (such as horizontal, vertical, 45 degree etc) can be set by holding down on the Shift key while moving one of the end points. Hold down on the Ctrl key while moving one of the end points to maintain the current slope (angle) of the trend line.
Locking to Common Angles

Detailed information about the trend line can be found if you place the mouse cursor over the trend line and leave it there for 2 seconds.

Several operations for working on trend lines can be found by right mouse clicking on the line to show its context menu.

1. **Create Alert** – Create an alert when the price crosses the trend line (see Component Alerts section)
2. **Show Info** – Shows information about the trend line
3. **Show Angle** – Displays the angle of the trend line (in degrees)
4. **Relative End Point** – Calculates the end point relative to the start point instead of using a specific time/value for the end point
5. **Extend** – Extends the Trend Line to the Right
6. **Extend Left** – Extends the Trend Line to the Left
7. **Show Midpoint** – displays the midpoint on the line
8. **Flip Line** – Flips the values on the start and end points
9. **Circle Radius** – Draws a circle using the trend line as the radius
10. **Circle Diameter** – Draw a circle using the trend line as the diameter
11. **Rotate 90 Degrees** – Rotates the trend line 90 degrees clock wise
12. **Rotate 45 Degrees** – Rotates the trend line 45 degrees clock wise
13. **Make Lines Parallel** – If you select multiple trend lines this will make them all parallel to the primary line (the one with the green resize points)
14. **Make Lines Parallel and Equidistant** – If you select multiple trend lines this will make them all parallel to the primary line (the one with the green resize points) and equidistant between the top and bottom lines.

![Trend Line Operations](image)

3.16.7 Custom Tools

Custom tools are based on existing mouse tools. A custom tool allows you to configure the default properties of the component that is drawn using the tool. For example, you could create a custom trend line tool that draws a blue dashed line (instead of a black solid line).

Custom tools can be created from the **Preferences Dialog** (*Configure -> Preferences* from the Console menu bar). Click on **Tool Bar**, then on **Custom Tools**.
From the Custom Tools section, click on the add button (plus sign) to open the **Add Custom Tool** dialog. The tool must be based on an existing tool, select this from the **Base Tool** drop down (Line tool in this case). Optionally, you can change the color(s) for the tool icon (to make it more distinguishable). For the purposes of this example we will choose blue as the primary icon color.

Click the **Customize** button to open the **Component Properties** dialog and adjust the default settings. In this case we would like to create a blue dashed line. This can be adjusted from the **Format** tab.
After clicking the OK button in the two previous dialogs, you will see the custom tool added to the list below:

The next step in using the custom tool is to add it to a tool bar so it can be accessed using the mouse. Click on the Tool Bar tab to customize the tool bar. In this case we are going to customize the Top Tool Bar to add our Blue Dashed Line tool to the left of our tools drop down.
After making the modifications above, the Blue Dashed Line tool will be added to the top tool bar (see below). Click on the button to activate the custom mouse tool. Note: the tool tip for this button will display the name of the tool.

The screen shot below illustrates the new tool in action creating a blue dashed line:
3.16.8 Tool Groups

**Tool Groups** may be used to create a custom drop down button for organizing existing and custom tools. This can help to optimize the available space on the tool bar(s). **Tool Groups** can be created from the **Preferences Dialog** (Configure -> Preferences from the Console menu bar). Click on **Tool Bar**, then on **Tool Groups**. Click on the add button (plus icon) to create a new **Tool Group**.
Choose a name for the tool group and add the desired tools from the Available Actions list to the Tool Group Actions list. Click on the OK button to create the tool group. Note: the name identifies the tool group and will also be used as the tool tip.

The newly created Tool Group will be added to the Tool Groups list in the Preferences dialog. The icon for the first tool in the tool group will be used for the tool group.

The next step is to add the tool group to a tool bar so it can be used. Click on the Tool Bar tab in the Preferences dialog and select the Top tool bar from the Tool Bar drop down. In this case we will add the My Tools tool group just after the Blue Dashed Line tool that we created in the previous section.
The screen shot below shows the new tool group added to the top tool bar. When you click on the drop down you will see the tools that were added in this tool group.

### 3.16.9 Visibility

Visibility is a very useful feature in MotiveWave™ that enables you to specify the bar sizes where a component is visible. This can be very useful to avoid clutter when switching bar sizes on a chart. Visibility setting can be set from the Properties dialog or via the right click menu on the component.
3.16.10 Object Viewer

The **Object Viewer** is a convenient dialog for managing components on a chart from a single location. Components can be deleted from the chart and you can adjust the visibility and draw order. The **Object Viewer** can be displayed from the top menu bar: *View -> Display -> Object Viewer*
3.17 Ratios

MotiveWave™ provides many different options for identifying time and price ratios. Fibonacci ratios are perhaps the most commonly used ratios for analysis. Available components for Fibonacci analysis can be found under the Fibonacci tab of the Components panel (not available in all editions):

The screen shot below shows an example of a Fibonacci Retracement. Yellow resize points can be used to change the position of the labels and length of the ratio lines.
MotiveWave™ provides a lot of flexibility for working with ratios. If you would like to modify the ratio properties for a particular component, right click on a ratio label and choose *Ratio Settings* (or just double click on the label).

The *Ratio Settings* option will open the **Properties** dialog for the component and switch to the **Ratios** -> **Ratios** tab.
3.17.1 Customized Ratios

For each ratio, use the check box to the left to enable/disable. The input field can be used to enter the ratio (in percent). Click on the edit button (pencil icon) to the right to specify how the ratio should be formatted.

The custom settings chosen above for this ratio will look like the following:
3.17.2 Ratio Display Preferences

The **Display** tab allows you to change how the ratios are displayed. The settings on this tab apply to all ratio labels/lines in the component (unless explicitly adjusted for each ratio, see previous section).

![Ratio Display Preferences](image)

3.17.3 Ratio Presets

**Ratio Presets** can be very useful save a ratio configuration and apply it to another component. This can help to avoid a lot of duplicate work. Use the **Save Preset** button to save the current ratio configuration for later use.
When you save the preset, you will need to choose a name. Enter the name in the **Save Ratio Preset** dialog (see below) and click the **Save** button.

Right click on a ratio label and choose **Ratio Preset -> <Preset Name>** to quickly apply a preset to a component. In the example below, we are going to choose **My Ratios** that we defined above:
3.17.4 Global Ratio Preferences

Global ratio preferences can be configured in the Preferences dialog from the Ratios tab. This section has two sub tabs, Presets and Defaults:

The Defaults section enables you to assign the default presets to each type of ratio component. Ratio components consist of retracements, fans, circles, Elliott Waves etc.
3.18 Time/Price Guides

Guides can be added to the vertical and time axes. A guide is essentially a vertical (or horizontal) line that has an attached indicator to show its value. There are two types of guides:

1. Price/Value Guide – Displays a horizontal line with an attached indicator in the vertical axis
2. Time Guide – Displays a horizontal line (across plots) with an attached indicator in the time axis

Guides can be added to a chart from the right click menu of the axis (choose Add Guide). This menu can also be used to edit the guide or remove it. The location of the guide can be changed by clicking and dragging it.
3.19 Percent Change Charts

Normally the price plot shows the historical prices. Percent change charts are an alternate view that shows the change in the price between each bar as a percentage movement. A percent change chart can be displayed by changing the bar type from the drop down on the tool bar to **Percent Change**.
By default, percent change charts are calculated from the left most point of the chart. This can be changed to a specific bar by right clicking on the chart where you would like the calculation to begin.

Two dashed lines will be displayed to visually indicate where the charts are being calculated (see below).
When combined with the Instrument Overlay, you can compare relative moves between instruments directly on one chart:

3.20 Studies
MotiveWave™ has over 275 built in studies that can be used to display information on the price plot or separately in a plot below the price.

There are essentially two types of studies:

1. Overlays – display information that is drawn on top of an existing plot (most typically the price plot)
2. Study Plots – display information that is displayed in a plot that is separate from the price plot.
3.20.1 Adding a Study

A study may be added to a chart by choosing one of the available studies can be found under the Study menu from the top menu bar. This menu organizes some (not all) of the studies into logical groups (based on author or function). The Add Study option enables you to search for a study instead of trying to find it in a sub-menu. For convenience, a Recent menu is available to access recently used studies.

If you choose Add Study, you will see the following dialog. This is a convenient way to search for a study by typing it in into the Filter input (see below):
When you add or edit a study you will see the study dialog similar to the one displayed below. Each study will have different settings and configuration options. The available tabs will depend on the study, but all study dialogs will have an Options tab and a Signals tab (if it generates signals).

Adjust the settings for the study and click on the Create button to add the study to the chart. For convenience, you can click on the Save Defaults button to save the study settings for the next time you create this study.

The following screenshot shows the Simple Moving Average (SMA) study from the Study dialog above. Also shown is a Study Plot for the MACD study.
3.20.2 Editing a Study

If you would like to edit the settings on a study simply double click or right click and choose Edit Study.

3.20.3 Study Options

All studies will have an **Options** tab as the last tab when you create or modify its settings. This tab will contain different values if it is an overlay or a study plot.
3.20.3.1 Overlay Plot

When you create an overlay study, by default it will use the **Price Plot**. Optionally, you can choose one of the existing plots to display the study. When you change the graph for the study, it will change the input options. For example, if you want to display a simple moving average (SMA) on an RSI study plot, you would choose the RSI(C,14) plot from the **Options** tab. When you choose this, the Input field (under the **General** tab) will be updated to reflect the inputs available from the RSI plot.

3.20.3.2 Study Bar Size

By default when you create a study, it will use the bar size of the chart. When the chart bar size changes, the study will be automatically updated to reflect the new bar size. MotiveWave™ does allow...
you to choose a specific bar size for the study. This allows you to, for example, display a 1 day SMA (Simple Moving Average) on a 15 minute chart. This feature also applies to study plots so you could display a 10 minute RSI on a 15 minute chart (see example below):

### 3.20.3.3 Study Plot Overlay

Study plots may be overlaid on other plots. You may have noticed this feature already with the Volume overlay on the default layout of the Console:
You can change the overlay plot for a study from the **Options** tab. A study plot can be overlaid on the Price Plot or other study plots. The following examples show a CCI plot on the Price Plot and an RSI plot on a Stochastic plot:

![Plot Overlay](image)

### 3.20.3.4 Study Visibility

For convenience, you can specify that a study is only visible on certain bar sizes. This is similar to the visibility feature for components. By default a study is visible on all bar sizes. You can change this from the **Options** tab:
3.20.4 Signals

Some studies generate signals. Signals occur when a specific event occurs with the study. For example, a signal may be generated in a CCI study where the CCI value crosses above the top guide. These signals can be used to show alerts, play sounds or even send an email notification. Note: if you want to send emails, you will need to configure your email (SMTP) settings in the Preferences dialog (Configure -> Preferences from the Console menu bar). You will find these options under the Email tab.
3.20.5 Instrument Overlay

An instrument can be overlaid on top of the price plot by choosing Study -> Instrument -> Instrument Overlay from the top menu bar. This action will open the dialog displayed below. Type (or select from the drop down) the instrument that you would like to overlay in the Instrument field. Click on the Create button to add this overlay to the price plot. This dialog has the following elements:

1. **Instrument** – Type or select the instrument.
2. **Bar Type** – Choose the type of bar you would like to display for the overlay (default is a line chart)
3. **Line Source** – If a line chart is chosen, this option allows you to choose the input source for that line (i.e., closing price, opening price etc)
4. **Shift** – the number of bars to shift the study forward (negative value for backward). Uncheck Lock Shift to enable dragging of the overlay backward or forward using the mouse.
5. **Style** – For line charts, choose the color, thickness and style of the line.
6. **Show Axis** – displays the axis for the instrument on the left hand side of the price plot
7. **Inverted** – Click to display the overlay upside down
8. **Bar Updates** – Click to enable live updates to the overlay instead of updates on the close of the bar
9. **Show Legend** – Shows the overlay in the study legend area
10. **Show Label** – Displays a label at the end of the overlay for the Instrument symbol

The example below shows an instrument overlay for the USD/CAD pair on top of the price plot for the EUR/USD pair. The axis for the USD/CAD pair is displayed on the left hand side and has indicators for the current prices. With Auto Scale enabled, dragging the chart left or right will automatically scale the values for the overlay.
The vertical scale of the overlay can be adjusted by clicking and dragging the space between the overlay axis and the price plot. Dragging from the top or bottom will add more top/bottom space. Drag from the middle to adjust both at the same time.

If auto scale is disabled, you can click and drag the overlay up or down to adjust the location of the overlay relative to the main instrument axis.
The horizontal location of the overlay can be adjusted by changing the value of the Shift field in the **Instrument Overlay** dialog. A positive value will shift the overlay into the future and a negative value will shift it into the past. If you uncheck the **Lock Shift** option you will be able to adjust the shift by dragging the overlay to the left or right with the mouse.
3.21 Strategies

A strategy is a special type of study that may be used to automate or partially automate trading. In addition to displaying the study information, a Control Box is made available that allows the user to activate/deactivate a strategy and view important runtime information.

MotiveWave™ supports two modes for strategies:

1. **Automatic** – Once the user activates the strategy, it will automatically buy and sell based on the internal logic.
2. **Manual** – In this mode, the user tells the strategy when it is OK to enter.

MotiveWave™ comes with around 30 built-in strategies. These can be found under the Strategy menu (from the top menu bar).
The following screen shot illustrates the Moving Average Cross strategy. This strategy will buy when the **Fast MA** crosses above the **Slow MA** and sell when it crosses below (see triangle markers below). Each strategy will have a control box (bottom left corner). This will enable you to edit the strategy and activate it. The control box also displays status information.

### 3.21.1 Manual Strategies

MotiveWave™ allows you to create strategies that respond to user input to enter or exit a position. This can be very useful as a way to help direct and manage exit points for user initiated trades. For an example of how this works, see the Trade Manager strategy.
The following screen shots show the configuration options for **Trade Manager**. On the first tab (**Entry/Exit**) you can setup the entry order and up to 3 exit orders. The **Stop Loss** tab provides options for the stop loss order.

From the **Trade Manager Control Box**, you can choose Long (buy) or Short (sell). When you click the **Activate** button, the strategy will enter on the close of the bar.

Once the strategy is active, the title bar will flash (indicates an active strategy) and the **Activate** button will be replaced by **Cancel** (deactivates the strategy) and **Enter Now** (creates a market order to enter the position).
When a position is entered in the strategy, the labels in the control box will display the open position, current unrealized P/L (profit or loss), target P/L, stop P/L among other information.

3.21.2 Strategy Configuration

The configuration options for a strategy will vary, but there are some settings that apply to many strategies.

The first panel is the Trading Options panel. This panel enables you to configure the following:

Trading Options:

1. **Trade Lots** – This determines the quantity on the orders that are used to entry and exit positions. The Trade Lot is multiplied by the default quantity to determine the actual quantity.
2. **Position Type** – Use this option to indicate if the strategy can have long and/or short positions
3. **Use Account Position** – Use the existing position that exists in the selected account.
4. **Enter On Activate** – If enabled the strategy will create an initial position when you activate the strategy.
5. **Close On Deactivate** – If a position is open when the strategy is deactivated, it will be closed at market price.
6. **Bar Updates** – If enabled, the strategy will respond to live bar updates instead of waiting until the close of the bar.
7. **Underlay** – If enabled, the strategy will be drawn behind the price bars.

**Trading Sessions:**

The **Trading Sessions** section enables you to define sessions where the strategy may be active. In between trading sessions, the strategy will be automatically deactivated.

1. **Session 1** – defines the first trading session with a start and end time
2. **Session 2** – defines the second trading session
3. **Time Zone** – optionally specify the time zone for the hours defined in Session 1&2
4. **Close On Session End** – Closes an open position when the session ends

---

**Strategy Panel**

The **Strategy Panel** tab allows you to choose what labels are displayed on the control box. The available labels will depend on the strategy.

1. **Show Position** – displays the current open position
2. **Show Entry Price** – shows the average entry price for the open position
3. **Show Unrealized P/L** – shows the current unrealized profit/loss for the open position
4. **Show Realized P/L** – shows the current realized P/L
5. **Show Stop P/L** – shows what the profit/loss would be if the stop loss level is reached
6. **Show Target P/L** – shows that the profit/loss would be if the target level is reached
7. **Show Risk Ratio** – shows the risk level (target p/l divided by stop p/l)
8. **Show Total P/L** – current total profit/loss since this strategy was activated
### 3.22 Software Development Kit (SDK)

Custom studies and strategies can be programmed using our Software Development Kit. For more information on this, please visit our website: [http://www.motivewave.com/support/sdk.htm](http://www.motivewave.com/support/sdk.htm)

### 3.23 Tool Bar

A tool bar is available from the Console or from a Chart Window and contains a convenient set of buttons for performing common operations on a chart. This tool bar may be configured from the *Preferences* dialog (*Configure -> Preferences* from the Console menu bar). Additional tool bars may be added to the bottom or sides of the window.

Actions can be added or removed from a tool bar by selecting them on the right side (to add) or left side (to remove or re-order) and use the left and right arrow buttons in the center. You can re-order the buttons and add separators (or spacing) by selecting the action on the right and side and using the buttons to the far right.
Additional tool bars can be added to the windows by selecting the desired tool bar from the drop down and checking the **Enabled** box to the right.
3.24 Lock Studies

The Lock Studies feature is a convenient way to keep the current set of studies on a chart when you change the instrument. Choose View -> Lock Studies from the top menu bar to enable this feature on the selected chart. To change the instrument on a chart, type the new symbol into the Quick Search box on the left side of the tool bar and press the Enter key.

The following two screen shots illustrate the usage of the Lock Studies feature.
3.25 Lock Scroll

Lock scroll is a convenient way to maintain the same position across multiple charts when using the scrolling feature to move forward or backward on the historical price axis. Choose View -> Lock Scroll (from the top menu bar) or use the button available on the tool bar to enable this feature.

When this feature is enabled all charts that are part of the same Link Group will scroll to the same position when one of the charts is scrolled. If the chart is not part of a link group, but rather on a Console page, all charts that are on the same page will scroll with chart.

3.26 Study Templates

For convenience, studies can be organized into templates. A template contains one or more studies with specific settings. To create a template, simply add and configure all of the studies you want to
include on a chart. When you are satisfied with the studies and their settings, choose File -> Template -> Save As Template (from the top menu bar, Note: File -> Chart -> Template -> Save As Template from the Console).

A study template can be applied to another chart by choosing File -> Templates -> <Template Name> from the top menu bar (Note: File -> Chart -> Templates -> <Template Name> from the Console). Short cut keys are available to make this more convenient. Short cut keys are Alt + 1, Alt + 2 etc where the number key applies the template in the order they were created.
3.26.1 Removing a Template

To remove a template from a chart (including any associated plots). Right click on the template name (in the study legend).
3.26.2 Managing Templates

Your existing templates can be managed from the Manage Templates dialog. Choose File -> Templates -> Manage Templates (from the top menu bar). From this dialog you can rename, delete or change the order of the templates. The template order affects the short cut keys (Alt + 1, Alt + 2 etc). Changing the order will affect which template applies to each short cut key sequence.

3.26.3 Import/Export Templates

For convenience study templates can be exported and imported into a workspace. This can be useful for sharing templates or moving them between workspaces. Both of these operations can be done from the Manage Templates dialog (see previous section). The Import/Export buttons can be found at the bottom of the dialog.

3.26.4 Template Preferences

Preferences for study templates can be found in the Preferences dialog. Click on Chart then on Templates. A default template can be configured (check the Use Default option). This will be displayed whenever you create a new chart.
The **Link Templates** option will apply a template to all charts that are part of the link group (if configured, see the **Chart Linking** section).

![Template Preferences](image)

### 3.27 Linking Charts

Chart linking is a powerful feature that enables you to apply an action to a set of charts (instead of a single chart at a time). By default charts are unlinked (no link group assigned). There are a few different ways to assign a link group to a chart. The simplest is to choose the link group from the status bar at the bottom of the window (Note: this also works for DOM and Time/Sales windows).

![Link Chooser](image)

There are three modes for linking charts:

1. **Instrument (Symbol)** – In this mode, changing the symbol on one chart will change all charts in the link group to the same symbol
2. **Time (Bar Size)** – If the bar size is changed on a chart in this mode, all linked charts will change to the same bar size
3. **None (Replay Mode)** – This mode is for linking charts together for use in replay mode (linked charts are part of a replay group)
Link modes can be chosen for each link color individually. These options can be found in the **Preferences** dialog (Configure -> Preferences from the console menu bar).

Other windows such as the DOM and Time/Sales windows can also be given a link group. In the example below, two charts and a DOM Window have been assigned the same link color. Choosing a new symbol from the quick search box from one of the windows will automatically change the symbol for all windows in the link group.

**Linked Example Step 1**
3.27.1 Linking With Templates

As discussed in the Study Templates section the linking feature can be used in conjunction with the Study Templates. If enabled (see Preferences dialog, Chart -> Templates tab), applying a template to one chart in the link group will apply the template to all charts in the link group.

3.27.2 Link All

If you are working with the Console window (or a Desktop), you will notice an additional linking option, Link All. This option will link all charts that are on the current page. This provides a convenient way to link all the charts on a page with one click (instead of choosing a link for each chart).
3.28 Working with Chart Windows

3.28.1 Compact Mode

Compact mode strips away the tool bar, menu bar and status bars to maximize the chart area on a chart window. Use the compact/uncompact button on the right hand side of the title bar to switch between regular and compact modes.

The screen shot below illustrates a chart window in compact mode. Notice that the chart area fills the entire window to optimize the use of screen space. Click on the uncompact button on the tool bar to return to normal mode.
The behavior of compact mode can be configured in the Preferences dialog (Configure -> Preferences from the console menu bar). This allows you to specify what elements should be displayed in Compact Mode.
3.28.2 Tile Windows

The Tile Windows feature is useful to arrange your charts on a single monitor without having to position the windows manually. Start by arranging the chart windows roughly where you would like to place them. Once you have done this, right click on the title bar of one of the chart windows and choose Tile Windows (alternatively, press Ctrl + W). Note: on Mac OS X choose Window -> Tile Windows from the top menu bar.
3.28.3 Cascade Windows

Similar to the Tile Windows feature, Cascade Windows arranges the windows that are on the screen on top of each other offset from the top left corner. Choose Window -> Cascade Windows from the top menu bar to arrange the windows in this fashion.
3.28.4 Window Sizes

For convenience, the window size can be set from the Window menu (Window -> Window Size -> <Size>). This can be a useful feature for taking a screen shot or video. Choose Custom to specify a size that is not one of the presets.

3.29 Replay Mode

Replay mode is a very useful feature that enables you to go back in time and replay market data. This can be very useful to practice your trading or to test your custom studies and/or strategies. The replay mode control can be accessed from the chart menu bar: View -> Replay Mode (Note: there is also a button on the right hand side of the tool bar). When you click this menu item you will see the Replay Mode bar appear at the bottom of the chart.
Replay mode can be started by choosing a start date and pressing the power button.

Use the play, fast forward, reverse and stop buttons to step forward through the data. These buttons work as follows:

1. **Rewind** – This will restart the replay mode from the beginning
2. **Play** – Step forward in time by 1 tick
3. **Forward** – Play ticks until the next bar is reached
4. **Fast Forward** – Play ticks continuously
5. **Stop** – Stop playing ticks. This is only active if forward or fast forward buttons have been clicked above.

When you are working in replay mode will work as if you are trading live back in that time frame. A special replay account is created to manage orders, positions and historical trades.

### 3.29.1 Replay Settings

Replay settings can be accessed by clicking the gear icon on the right hand side of the **Replay Mode** bar.
Replay Settings Dialog

Replay Data Settings:
The following settings apply to the playback of data in replay mode:

1. **Source Data** – Options for source data include:
   a. **Bar Data** – Each bar is used to generate 4 ticks: open, high, low and close
   b. **Minute Data** – Minute data will be loaded from the data service to generate ticks (each minute bar will have 4 ticks: open, high, low and close)
   c. **Tick Data** – If your broker/data service provides historical tick data, then this may be used
2. **Generate Ticks** – If this is enabled MotiveWave will generate a set of ticks to (beyond OHLC) for playback. This option does not apply to the Tick Data option
3. **Step Until Price Change** – If enabled it will keep playing ticks until the price changes when pressing the play button (instead of a single tick at a time).
4. **Real Delay** – If this option is checked, MotiveWave will simulate the delay between ticks by using the tick timestamps. Use this if you would like to simulate the actual playback of ticks in real time
5. **Speed Factor** – Applies to Real Delay option above. Allows you to speed up (or slow down) the playback of ticks in real time
6. **Tick Delay** – this is the delay to add between the play of each tick.
7. **Bar Delay** – this is the delay to wait between the playback of each bar.
8. **Replay Link** – Use these options to link the replay mode across multiple charts.

Replay Account:
The replay account is useful if you intend to place trades in replay mode. If this is enabled, a special account will be created (see Account page in the Console) to track all orders, positions and historical trades for the replay session.

1. **Account ID** – This is the name of the account ID that will track trades
2. **Base Currency** – This will default to your base currency, but you can change it if you like
3. **Cash Balance** – Opening cash balance when you enable replay mode
4. **Include Commissions** – Check if you want trade commissions to be included in the P/L calculations.
3.29.2 Linking in Replay Mode

The linking feature in MotiveWave™ enables you to use replay mode across several different charts at the same time. The following steps explain how to include multiple charts in the same replay session:

1. Select the charts that you want to include and choose the instruments and bar sizes
2. Choose the same link color for each chart (make sure the link type is “Replay”)
3. Edit the Replay Settings
4. Choose the link and press the “Update” button

The following screen shot shows 4 charts that are part of the Red group and using the same replay session:
Using replay mode inside of the Console (or a Desktop) can be much more convenient when Page linking is used (default). All charts that are part of the page will be included in the replay session.
Replay Session within a Page

3.30 Alerts

Alerts are a useful way to receive a notification when a particular event has occurred. This could be as simple as a price for a particular instrument has been reached or a trend line has been crossed. More advanced examples include comparing values from different studies.

Active alerts can be managed centrally from the Alerts panel in the Console. By default, this is included on the Home page. You can add an alerts panel anywhere in the console from the Add Tab button to the right of any panel tab.
3.30.1 Price Alerts

The simplest type of alert is a **Price Alert**. A price alert does not require a chart in order to execute. It will be triggered by the bid/ask or last price of an instrument. Price Alerts can be created directly from the Alerts panel or from the Price Axis of a chart.

The following dialog is shown when an alert is created from the Alerts panel. Alerts created from the **Price Axis** are similar except for the ability to choose an instrument (this is assumed from the chart).
Settings available in this panel are as follows:

1. Parameters
   a. **Condition** – This defines the criteria for triggering the alert. The first field (input) can be any of the ticker inputs (last price, bid/ask high/low etc). The last field can be an absolute price. Alternatively, it could be a relative value (click the Indicator box) such as Last Price, Best Bid or Best Ask. In the case of a Price Alert, this will be an absolute value in most cases. Three types of operators are available for comparison:
      i. **Crosses** – Input crosses above or below the second input
      ii. **Crosses Above** – Triggers the alert only if it crosses above the second input
      iii. **Crosses Below** – Triggers the alert only if it crosses below the second input
      iv. **Touches** – Triggers an alert if the target value is touched or crossed
   b. **Trigger Multiple** – If this option is checked, the alert will still be valid after it is first triggered. In this case this alert will be triggered indefinitely until it is explicitly cancelled.
   c. **Label / Comments** – These fields enable you to add your own text to an email notification that is sent when the alert is triggered

2. Notification
   a. **Show Alert** – If true the Alert History window will be displayed when the alert is triggered
   b. **Play Sound** – A sound will be played when the alert is triggered. This can either be the preset sound or a specific sound file that you can specify.
   c. **Send Email** – If enabled (and email sending has been configured), an email will be sent to the given email address when the alert is triggered.

3.30.2 Study Alerts
Alerts can be based on values that are generated as part of a study. These types of alerts execute in the context of a chart and require the chart to be open in order to be active. Similar to a price alert, you can create a study alert by right clicking on the vertical axis (of the Price Plot or a Study Plot) and choosing **Create Alert**.
Two types of comparisons can be made with a study alert:

1. **Absolute Comparison** – A study value is compared to a specific value (e.g., -0.1174 in the above example)
2. **Relative Comparison** – A study value is compared against another study value (in the same plot). Click on the *Indicator* field to enable a relative comparison.

The example below illustrates a study alert where the value of one study KAMA(C,20) crosses the value of another study (Tenkan-Sen(9)). The alert is displayed where the intersection point would be between these two values.
3.30.3 Component Alerts

Some components can be used to generate alerts. For example, you could create an alert for when a moving average crosses a trend line. If you would like to create this type of alert, right click on a trend line and choose Create Alert.
In the example below the study value KAMA(C,20) was chosen to cross the trend line. The alert label shows the current crossing value. Press the ‘C’ button to cancel the alert. The alert may be edited by double clicking the alert label or via right click and choosing Edit Alert.

3.30.4 Trading From Alerts

Trades can be placed when an alert triggers. Click on the Trade tab of the alert dialog to define an order that will be placed when the alert is activated.
Orders can be placed on a different instrument from where the alert was triggered. Market, Limit and stop orders are supported as order types. Optionally, you can attach a limit (profit) order and/or stop/trail order.

### 3.30.5 Advanced Alert Settings

Additional options on an alert can be specified from the **Advanced** tab. This tab enables you to adjust time times when the alert is applicable (or expires) and the display properties.

#### Time In Force

The **Time In Force** section allows you to set an expiry date/time for an alert and optionally define times of the day when the alert is active.
1. **Time Zone** – The dates and times specified in this section will use the same time zone defined for the chart. This may optionally be overridden by unchecking the Use Default box.

2. **Expires** – Check the Enabled field to the right to specify a date/time when the alert will expire and be removed.

3. **Session 1** – Defines a time of the day when the alert will be active

4. **Session 2** – Define a secondary time of the day when the alert will be active.

**Display**

The **Display** section allows you to override default display attributes for the alert.

### 3.30.6 Alert History

The Alert History window displays alerts that have been triggered in the past. Choose **View -> Display -> Alert History Window** from the top menu bar. If the chart where they were activated is still available, a **Chart** button will be available to view the chart that they originated from.

![Alert History Window](image)

Historical alerts are also visible directly on the chart. Icons are displayed when and where (what price) and alert occurred. If you place the mouse cursor over one of the alarm clock icons, you can view detailed information.
Alert history can also be found under the History tab of the Alerts panel (in the Console):

3.30.7 Alert Preferences

Global alert preferences can be configured in the Preferences dialog (Configure -> Preferences from the Console menu bar). The alert preferences will be found under the Alerts tab (see below).
3.31 Ticker Tape

Ticker tape displays a rolling set of prices for a selected set of instruments across the top of the Console, Desktop or Chart Window. This option can be turned on by choosing View -> Display -> Ticker Tape from the top menu bar.

The instruments and display of the ticker tape can be configured from the Preferences dialog (Configure -> Preferences from the Console menu bar). Click on the General tab, then on the Ticker Tape sub tab. This panel has the following options:

1. **Instruments** – Instruments may be added or removed by using the tool bar at the top of the list box on the left
2. **Font** – Font size for the instruments displayed on the ticker tape section
3. **Scroll Speed** – Relative speed for scrolling the instruments
4. **Show Ticker Tape** – Default for displaying the ticker tape in a chart window
5. **Show Change** – Shows the change since the day open
6. **Show Change %** - Shows the change since the day open as a percent
3.32 Short Cuts

MotiveWave™ provides a number of convenient ways to do common tasks quicker. This section explores some of these options.

3.32.1 Menu Short Cut Keys

You may have noticed already that when displaying a menu, a key combination is displayed on the right hand side for some of the items in that menu. This key combination may be used as a short cut to access that item without using the mouse to show the menu and select the item.

In the example displayed below, the short cut keystroke for accessing the Line tool is: Ctrl + Shift + L. This means that you can hold down on the Ctrl (Control key), Shift and press the L key on the keyboard (all at the same time) to switch your mouse tool to the line tool. You may find this to be much faster than using the mouse to select the tools drop down and choose the line tool menu item.
3.32.1.1 Custom Keyboard Short Cuts

Keyboard short cuts can be customized in the Preferences dialog (Configure -> Preferences from the Console menu bar). Start by unchecking the Use Default option. With this option unchecked, you can double click on any of the actions (or select and press the edit button) to assign a keyboard short cut.

From the Edit Shortcut dialog, simply press down on the key sequence that you would like to assign to the action. The key sequence will appear in the grey box (see below).
3.32.2 Mouse Wheel

If your mouse has a wheel, you can use this to perform the following actions on the chart:

1. **Time Shift** – Move the graph to the left or right (depending on wheel direction)
2. **Adjust Bar Width** – This will effectively zoom the graph in or out
3. **Adjust Vertical Space** – Changes the space available at the top or bottom of the graph

The default action for the mouse wheel is to time shift when it is moved back or forward. If you hold down on the Alt key and move the mouse wheel, it will adjust the bar width (ie zoom in or out).

This behavior can be adjusted from the Preferences dialog (Configure -> Preferences from the Console menu bar). Click on the General tab, then on the Mouse sub tab.

3.32.3 Mouse Click Options

Keyboard modifiers: **Shift**, **Ctrl** and **Ctrl + Alt** when used with a left mouse click can be configured to do specific actions. The default behavior is as follows:
1. **Shift + Click** – Creates *Text Comment*. When you perform this short cut an entry box will appear for you to enter text. Just type your comment and press Enter (or Esc) to create it.

2. **Ctrl + Click** – Creates a *Price Guide* at the location of the mouse.

3. **Ctrl + Alt + Click** – Creates a Time Guide at the location of the mouse.

These actions may be configured from the **Preferences** dialog (*Configure -> Preferences* from the Console menu bar). Click on the **Chart** tab then on the **Chart Settings** sub tab. The following actions are available to choose from for each click shortcut:

1. **Price Guide** – Creates a price guide at the mouse location
2. **Horizontal Line** – Creates a horizontal line at the mouse location (extended left and right)
3. **Time Guide** – Creates a time guide at the mouse location
4. **Vertical Line** – Creates a vertical line (extended up and down) at the mouse location
5. **Text** – Creates a text box to enter text
6. **Note** – Creates a Note component
7. **Box Callout** – Creates a Box Callout component
8. **Balloon Callout** – Creates a Balloon Callout component
9. **Line Callout** – Creates a Line Callout component
10. **Annotation** – Creates an Annotation component
11. **Curly Annotation** – Creates a Curly Annotation component

### 3.32.4 Other Shortcuts

The following are some other shortcuts that you may find useful.

*Ctrl + Mouse Drag (Copy)*
Hold down on the Ctrl key and drag a component to create a copy of it. This can be very useful for example to create a line that is parallel to another line. The mouse cursor will change to the following to indicate that you are creating a copy:

**Revert To Default Tool (Space Bar)**

When switching to a mouse tool, you can quickly switch back to the default mouse tool (Time Drag Tool) by pressing the *Space Bar*. This can be more convenient than pressing Ctrl + Shift + D. Alternatively, you can change the behavior of the mouse tools to automatically revert to the default tool when an action is completed. This can be adjusted from the Preferences Dialog. Click on the *Chart* tab then on the *Chart Settings* tab.
4 Trading

There are lots of ways to place and manage trades within MotiveWave™. In this section will explore some of the convenient features for dealing with orders, positions and trades. Some of the trading features such as supported order types may vary depending on the broker you have chosen for the workspace.

4.1 Account Management

The Account page in the console provides a convenient view of current account information as well as open orders, positions and historical trades. The columns displayed in each section will vary depending on the broker or data service that you chose for your workspace.

This is the default layout for the Account page. You can add these panels anywhere within the Console or Desktop. Simply click on the Add Tab button (Plus Icon) next to the existing tab where you want to add the panel.
4.1.1 Account Panel

The Account panel displays information about each available account in your workspace. The columns displayed will differ depending on the broker that you chose for your workspace. The Unrealized PL column is common to all brokers and displays the current unrealized profit/loss for all positions that belong to each account.

The Default column indicates which account is the default for placing orders. You can change the primary account by right clicking on the desired account and choosing Set As Default Account. This setting is important to avoid accidentally placing orders on the wrong account.
4.1.2 Orders Panel

The Orders panel displays the currently active orders in one convenient location. The **Group** column indicates orders that are linked as either OCO (One Cancels Other) or OSO (One Submits Other). The **Status** column displays the current order status (green for active). Click on the ‘C’ to cancel an active order.

Orders can be edited from here directly by clicking on the appropriate table cell (see below). If an order has outstanding changes, the status column will change to show a ‘T’ and a ‘D’. Click on the ‘T’ to transmit (submit) the changes to the broker or on ‘D’ to discard the changes.

Alternatively, right click an order to see additional options. Double clicking on an order will show the **Order Ticket** dialog.
4.1.3 Positions Panel

The Positions panel shows the currently open positions (and closed for some brokers). Individual positions can be closed (at market price) by clicking on the Close button (right hand side). If you would like to close all positions, right click on a position and choose Close All Positions.

If you have enabled the simulated account, you can add positions manually by clicking the Add Position (Plus Icon) button on the top right corner of the panel. This is a useful feature if you would like to track positions that are managed outside of the broker or data service that you are using. The following diagram shows the Add Position dialog. It has the following fields:

1. **Instrument** – select the symbol for the instrument
2. **Opened Date** – This is when the position was originally opened
3. **Quantity** – Number of shares, contracts etc
4. **Avg Price** – Average entry price for the position
5. **Commission** – Optionally enter a commission to track fees.

For some brokers (such as FXCM) they provide a bit more information on position such as the recently closed positions. Specifically for FXCM hedging accounts, a summary tab is included to roll up individual position totals.
4.1.4 Trades Panel

The Trades panel displays historical trades (ie filled orders). Columns displayed on this page will vary depending on the broker chosen for the workspace. Some brokers only report a limited number of historical trades. For this reason, you should rely on the account management tools provided by your broker to ensure accurate reporting of historical trades.
4.2 Simulated Account

For convenience, MotiveWave™ has a built in simulated account that you can use to practice your trading. If you chose a data service for your workspace, then this account will be enabled by default. If you are using a broker, it is recommended that you use a demo account if provided by your broker instead. Broker demo accounts will provide a better simulation of their trading environment and supported order types and behaviors.

The simulated account can be configured from the Preferences dialog (Configure -> Preferences from the Console menu bar). Click on the General tab then on the Simulated Account tab. This panel has the following fields:

1. **Enabled** – Check this box to enable or disable this account
2. **Base Currency** – Base currency for the account
3. **Cash Balance** – Initial Cash Balance
4. **Fill Immediate** – If checked market orders will be filled immediately at the current bid/ask value instead of waiting for the next trade
5. **Include Commission** – If checked, commissions will be included when placing trades.
6. **Reset Account** – Click this button to reset the account back to the initial cash balance.

If you have the simulated account enabled, you will see an entry in the Accounts panel for this account. The account id will be ‘Simulated’.
4.3 Commissions

Commissions can be calculated by MotiveWave™ using the simulated account, in replay mode or as part of Strategy Back Testing. If you would like to include commissions, these can be configured from the Commissions dialog (Configure -> Commissions from the Console menu bar).

1. **Base Cost** – This is the base cost of a trade. Some brokers offer flat rates for commissions. If this is the case, just enter the cost here.
2. **Unit Cost** – Some brokers charge based on the number of units (ie quantity) that are part of an order (ie shares, contracts etc).
3. **Unit Size** – If a unit cost has been specified this is the lot size.

The above dialog enables you to define a commission structure that applies to each type of instrument. Some instruments may have their own specific commission structure. If this is the case, you can override this from the Instrument dialog (right click on the chart and choose Edit Instrument, click on the Commissions tab).
4.4 Order Presets

Order presets are convenient for defining default order attributes. Defaults can be defined generically by the type of instrument or specific to an instrument. General order presets can be accessed by choosing Configure -> Order Presets from the Console menu bar.

This dialog has a tab for each type of instrument. Each panel will have the following fields:

1. **Order Type** – Default type of order to be placed
2. **Time In Force** – Defines the expiration time of the order. Available types will depend on the broker.
3. **Trigger OTH** – If checked, the order can be triggered outside of regular trading hours
4. **Offset** – Default offset (in pips) from the current price when placing an order
5. **Limit Offset** – Default offset (in pips) from the current price when placing a limit order
6. **Stop Offset** – Default offset (in pips) from the current price when placing a stop order
7. **Trail Offset** – Default offset (in pips) from the current price when placing a trail order
8. **Default Quantity** – Default quantity when creating a new order
9. **Increment** – Increment (or decrement) size when adjusting the order quantity
10. **Preset Quantities** – The quantities in the list box will be available from a drop down menu next to each quantity field. These values are also available from Quantity Selector in the DOM.
If you would like to change the order presets for a specific instrument, edit the instrument (right click on a chart and choose *Edit Instrument*) and click on the *Order Presets* button at the bottom of the dialog.
4.5 Chart Trading

Perhaps the most convenient way to create orders in MotiveWave™ is by using the tools available from a chart. There are several ways to do this:

1. **Price Axis** – Trades can be placed directly from the price axis
2. **Buy/Sell buttons** – The Buy/Sell button labels can be optionally added to a chart
3. **Context Menu** – Use the trade items available in the context menu of the chart (right click)
4. **Trade Panel** – Use the trade panel that may be displayed on the right hand side of the chart
5. **DOM Panel** – The Depth of Market panel can be displayed on the right hand side
6. **Strategies** – As explained in the section: [Strategies](#)

4.5.1 Chart Orders

Active and filled orders may be displayed and adjusted directly on the chart. Click on the **Show Orders** button on the tool bar to toggle the display of orders on the chart.
The price of an order can be adjusted by clicking and dragging the order label up or down. By default the order will automatically be submitted with the modified price. This default can be changed in the Preferences dialog (see Order Preferences section). If “Auto Submit Modified Orders” is turned off, then you will need to press the ‘T’ button to transmit the modified order to the broker.

Double click on the order label to display the Order Ticket dialog. A context menu can also be accessed by right clicking on the order label.
4.5.2 Trade History

Historical trades can be displayed directly on the chart by clicking the Show Trades button on the tool bar. Detailed information on each trade can be displayed by placing the mouse cursor over one of the trade arrows.

4.5.3 Price Axis Trading

Orders can be created directly from the price axis by simply clicking where you want to place a limit order. If you move the mouse over the price axis, you will notice that the mouse cursor will change to a blue/red target (depending if you are above or below the current price). You will also notice that there is a label that shows the price.
Press the left mouse button once to create a limit order at that price using the default quantity for the Instrument (see Order Presets). **Note:** place the cursor above the current price to create a **Limit Sell** order, and below to place a **Limit Buy** order.

By default, this order will just be created (not submitted to the broker). You can optionally modify this order and click the 'T' (transmit) button to submit the order to the broker.

### 4.5.3.1 Price Axis Order Types

You can place different types of orders from the price axis by holding down on the following keys while clicking the left mouse button. The quantity for all of these orders will be the default quantity assigned to the instrument.

1. **No Key** – Limit Order, the limit price will be the value at the current mouse location
   a. **LMT** Limit Buy – cursor is below the current price
   b. **LMT** Limit Sell – cursor is above the current price
2. **Ctrl Key** – Stop Order, the stop price will be the value at the current mouse location
   a. **STP** Stop Buy – cursor is above the current price
b. **STP** Stop Sell – cursor is below the current price

3. **Shift Key** – Market Order, sell or buy at the current market price (best bid/best ask)
   a. **BUY** Buy Market – cursor is below the current price.
   b. **SELL** Sell Market – cursor is above the current price

4. **Ctrl + Shift Key** – Limit Order + Attached Limit & Stop orders. A limit order will be placed with the limit price equal to the current mouse location. A limit and stop loss order will be attached to the limit (parent) order.
   a. **LMT SL** Buy Limit + Sell Stop/Limit
   b. **LMT SL** Sell Limit + Buy Stop/Limit

The mouse cursor will change depending on which modifier key you are pressing when moving the cursor over the price axis.

### 4.5.3.2 Price Axis Context Menu

The context menu (right click on the price axis) also has a menu for creating orders (see diagram below).

![Price Axis Trade Menu](image)

**Right click on the Price Axis to show the context menu**

### 4.5.4 Buy/Sell Buttons

For convenience, buy and sell buttons can be added to the chart. These buttons are available as Chart Labels. Double click on the chart (or right click and choose Chart Settings) to open the Chart Settings dialog. You will find the **Buy Button** and **Sell Button** labels under the Label tab.
Enable Buy/Sell Buttons

If you would like to create a buy or sell order, click on the Buy or Sell buttons that are directly on the chart. This will open an Order Ticket dialog that you may use to create your order.

The Order Ticket dialog may look different depending on the broker you are using. The following dialog is from a workspace configured for CQG:

Click either of these buttons to show the order ticket dialog
4.5.5 Context Menu

The context menu (right click on the chart area) has options for placing orders and adjusting trading settings.

4.5.6 Trade Panel

The trade panel is a convenient tool for managing orders and positions from the chart. This panel can be displayed by choosing View -> Display -> Trade Panel from the top menu bar (or press Alt + T). There is also a button available on the tool bar that toggles the display of this panel.

The Trade Panel has three tabs that provide different trading options.

4.5.6.1 Position Tab

The Position tab may be used to manage your current position for the chart instrument. It has the following elements:

1. **Buy Market Button** – Creates a market order to buy the given quantity at the market price
2. **Sell Market Button** - Creates a market order to sell the given quantity at the market price
3. **Quantity** – This is the quantity for the market orders. It will default the value in order presets
4. **Flatten Button** – If you currently have an open position, this button will close the position at market price
5. **Cancel All** – If you have open orders for the chart instrument, this will cancel these orders
6. **Break Even** – Creates an exit order at the break even price.
7. **Reverse Button** – If you have an open position this will close that position and open a position in the opposite direction. For example, if you were currently long 10K, this would close the long position and open a short position for 10K
8. **Account Choice** – Enables you to choose the account for the orders
9. **Position Label** – Displays the current position (N/A for no position). If the label background is blue, then the position is long. Short positions will have a red background as well as a negative number for the quantity.
10. **P/L Label** – Displays the current unrealized profit/loss for the open position. A loss will be displayed with a red background (and a negative sign). A profit will be displayed with a blue background. If there is no open position, this label will display N/A.

### 4.5.6.2 Order Tab

The **Order** tab is used to create or modify existing orders. New orders can be created by clicking on the Buy or Sell buttons. An existing order can be modified by selecting it on the chart (left click on the label).

1. **Buy Button** – Indicates if the order is a buy or sell. If no order is selected on the chart, you may click on this button to create a buy order.
2. **Sell Button** – Indicates if the order is a buy or sell. If no order is selected on the chart, you may click on this button to create a sell order.
3. **Quantity** – quantity for the selected order. This will default to the order preset if it is a new order.
4. **Order Type** – list of available order types (broker dependent). The selected choice will influence the visible fields below (ie limit price, stop price etc).
5. **Limit/Stop Price** – Depending on the type of order these fields may be visible underneath the Order Type field.

6. **Time In Force** – effective time for the order. Day orders will expire at the end of the day. GTC orders last until they are cancelled (Good Till Cancelled). The options available in this field will vary depending on the broker.

7. **Limit** – Use this option to attach a limit (profit) order. This order will be activated when the primary order is filled

8. **Stop** – Use this option to attach a stop order. This order will be activated when the primary order is filled and will be an OCO (one cancels other) order with the limit order above.

9. **Trail** – Use this option to attach a trailing stop order (instead of the stop order above).

10. **Submit/Modify Button** – Click this button to submit the order to the broker. This button will have a red background for sell orders and a blue background for buy orders

11. **Discard/Cancel** – Discards (for new orders) or cancels the order

12. **Account Choice** – Account for the order. For new orders, this will default to the Primary account (set in the Accounts panel).

![Image of Trade Panel – Order Tab]

### 4.5.6.3 Bid/Ask Tab

The Bid/Ask tab shows a Buy/Sell box (with best bid and best ask prices). This tab is convenient for placing buy and sell orders at market and monitoring the spread between the bid/ask prices. You can double click on either the Sell or Buy boxes to submit a market order.
4.5.6.4 Entry/Exit Strategies

Entry/Exit strategies provide a convenient way to place combinations of orders in a single click. The entry/exit section can be found on the Trade Panel as well as the DOM (Depth of Market, hidden by default).

The following screen shot shows the Entry/Exit section of the Trade Panel. Strategies can be created, modified or removed by clicking on the edit button located in the top right corner of the section.

If you would like to execute a strategy, select it from the available strategies drop down and press the execute button. Parameters such as Lot Size, Time In Force and Offset Size can be adjusted in the fields below.
MotiveWave™ comes with several built-in strategies that you use or modify to suit your needs:

1. **Breakout** – Creates buy/sell stop OCO (one cancels other) orders above and below the current market price. This can be useful if you are expecting the price to shoot up or down in the near future and you want to get in on the trend.
2. **Fade** – Creates limit OCO orders above and below the current market price.
3. **Brk Up/Fade Down** – Creates a Buy Stop Order (above the current price) and a Buy Limit Order (below the current price) (OCO Orders) to enter the market long.
4. **Brk Dn/Fade Up** – Creates a Sell Stop Order (below the current price) and a Sell Limit Order (below the current price) (OCO Orders) to enter the market short.
5. **Bracket Exit** – Creates a limit order to exit a position and a stop order as a stop loss. Both of these orders are OCO orders.
6. **Scale Out – 2** – Creates two limit exit orders and two stop loss orders to scale out of a position.
7. **Scale Out – 3** – Creates three limit exit orders and three stop loss orders to scale out of a position.

Entry/Exit strategies can be managed by clicking on the edit button to show the dialog below.

Click on the **New** button to create a new strategy or select an existing strategy and click on the **Edit** button. The **Entry/Exit Strategy** dialog will be displayed to allow you to configure Entry and/or Exit orders for this strategy. If it has both types of orders, the exit orders will be created when the entry orders are filled. The following fields apply to this dialog:

1. **Name** – This is the name of the entry/exit strategy and will be displayed in the drop down
2. **Absolute Offset** – By default the offset will be multiplied by the Offset Size in the Entry/Exit panel. If you specify an absolute offset the offset (ticks) will be used as is.
3. **Offset** – This is the distance (in ticks) from the current price. If the absolute offset is not checked, this value will be multiplied by the offset size in the Entry/Exit panel.
4. **Lots** – This is the number of trade lots that will be setup as the quantity for the order. This number will be multiplied by the Lot Size field in the Entry/Exit panel.

**Entry Orders**
You can specify up to five entry orders for the strategy. Each entry may have one or two orders. If two orders are specified, then these orders will be submitted as an OCO (One Cancels Other) pair.

**Entry/Exit Strategy Dialog**

This dialog allows you to define a custom entry and/or exit strategy. Relative (vs absolute) offsets may be used to have different offset values per instrument. In this case the actual offset will be a multiplier of the Offset field in the Order Presets.

### Entry Orders

Select the entry orders below. Each entry may consist of 1 or 2 orders. If two orders are specified, they will be submitted as an OCO order (One Cancels Other). The Offset and Lots fields are relative to the Order Presets for the instrument.

- **Entry 1**: Limit -> Sell, Offset: 1.5, Lots: 1 ½
- **Entry 2**: Limit -> Buy, Offset: 1, Lots: 1 ½
- **Entry 3**: Limit -> Sell, Offset: 1, Lots: 1 ½
- **Entry 4**: Limit -> Buy, Offset: 1, Lots: 1 ½
- **Entry 5**: Limit -> Sell, Offset: 1, Lots: 1 ½

### Exit Orders

Similar to the entry orders, you can specify up to 5 exit orders. If this strategy has entry orders, then these orders will be created after the corresponding entry order has been filled. Each exit can have a limit (profit taking order) and a stop/trail order (stop loss order). These orders will be submitted as an OCO (One Cancels Other) pair. If **Auto Adjust Size** is checked, the lot size will be adjusted to match the currently open position.
4.5.7 Preferences

The behavior and appearance of orders can be modified from the **Preferences** dialog (Configure -> Preferences from the Console menu bar). Click on the **Orders** tab.

1. **Price Axis Trading** – Enables or disables the ability to trade from the price axis
2. **Buy/Sell Box Trading** – Enables or disables the ability to trade from the Buy/Sell boxes
3. **Use Pips for Attached Orders** – Indicates if pips vs price should be used when determining the offset from the parent order.
4. **Confirm Closing Positions** – Displays a confirmation dialog when clicking on the close button for a position.
5. **Auto Submit Modified Orders** – If this option is enabled, dragging an order on a chart will automatically submit the price change to the broker (instead of requiring an extra step to transmit the change by clicking on the ‘T’ button)
6. **Send Email on Filled Order** – Sends an email to the configured email address when an order is filled. Note: you must configure your email settings (see Email tab)
7. **Send Email on Rejected Order** – Sends an email to the configured email address when an order is rejected. Note: you must configure your email settings (see Email tab)
8. **Show Client OCO Warning** – Display a warning when placing a client OCO order. Some brokers do not support server side OCO orders. In these cases MotiveWave™ will simulate the OCO order on the client side.
9. **Show Client Attach Warning** – Similar to the option above, MotiveWave™ will display a warning to remind you that the attached order is a client order (not submitted to the server initially).
10. **Create Order** – Mouse click to create (but not submit) an order
11. **Show Order Ticket** – If checked, the Order Ticket dialog will be displayed when creating an order.
12. **Auto Submit** – Mouse click to create and submit an order (double click by default)
13. **Price Axis Key Modifiers** – This section may be used to customize what types of orders may be created from the price axis.
   a. **Default (No Key)** – defines the type of order created when the mouse is clicked with no modifier key
   b. **Shift Key** – defines the type of order created when the mouse is clicked while pressing the Shift Key
   c. **Ctrl Key** – defines the type of order created when the mouse is clicked while pressing the Ctrl Key
   d. **Ctrl + Shift Key** – defines the type of order created when the mouse is clicked while pressing the Ctrl and Shift Keys
The Display tab provides options for displaying orders on charts:

Order Preferences

Limit, stop and market orders can be created (and submitted) directly from the price axis. Create Order will create the order on the graph giving you the opportunity to transmit the order (clicking the “T” button). Auto Submit will save time by creating the order and automatically submitting the order to your broker.

Order quantities can be configured in Order Presets. Keyboard modifiers (Ctrl, Shift, and Ctrl+Shift) may be configured to place different order types from the price axis. Hint: if you are above a price indicator, hold the Alt key to place an order.

Price Axis Key Modifiers

These fields may be used to change the price axis behavior:

The Display tab provides options for displaying orders on charts:
4.6 *Depth Of Market (DOM)*

MotiveWave™ provides a Depth of Market (DOM) feature that allows you to see bid and ask prices/sizes beyond the best bid and best ask provided this is supported and permissioned from your broker/data service. Depth of Market can be accessed as a panel on a chart, a panel in the console or from a separate DOM window (*File -> New -> New DOM Window* from the Console menu bar).

The following screen shot shows an example of a DOM window. Current position information can be found at the bottom of the window. The table area contains several different columns which are configurable from the Preferences dialog.

1. **P/L** – Displays what the profit/loss would be for your open position at each price interval. Profit levels are displayed with a light blue background, losses show in pink.
2. **Orders** – Shows active orders. Sell orders are in the left Orders column, buy orders are in the right Orders column. The example below shows a limit sell order for 1 contract on the right hand side. You can click and drag the label to adjust the limit price or cancel the order by clicking on the ‘C’.
3. **Bid** – shows the current bid sizes at each price level. For convenience a histogram is displayed in the background to show the size of the bid relative to the other prices.
4. **Price** – This is the price ladder. It shows prices in increments of 1 tick. The last price has a dark blue background and shows the last traded size. Best bid and best ask prices have yellow and green backgrounds. Day high and day low have blue and red backgrounds.
5. **Ask** – shows the current ask sizes at each price level. For convenience a histogram is displayed in the background to show the size of the offer relative to the other prices.
6. **Volume** – Displays historical price action at each price level. This column will update as live trades are made.
4.6.1 Trading From the DOM

By default the DOM is locked, this prevents trades from being placed directly from the table. Click on the Lock/Unlock button on the tool bar to enable trading from the DOM table. Limit and stop orders can be placed by clicking on the Bid and Ask columns. You will notice the mouse cursor changes when you move it over the bid and ask columns:

1. **Buy Limit** - This cursor will display over the Bid column and below the current best bid price. A limit order will be placed with the given quantity when a row is clicked with the left mouse button.

2. **Buy Stop** - This cursor will display over the Bid column and above the current best ask price. A stop order will be placed with the given quantity when a row is clicked with the left mouse button.
3. **Sell Limit**  
   - This cursor will display over the **Ask** column and above the current best ask price. A limit order will be placed with the given quantity when a row is clicked with the left mouse button.

4. **Sell Stop**  
   - This cursor will display over the **Ask** column and below the current best bid price. A stop order will be placed with the given quantity when a row is clicked with the left mouse button.

---

**Order Combinations**

Other types of order combinations can be created by choosing a different option from the order type drop down on the tool bar. The following example shows the **Limit + Stop/Limit** option. A limit order will be placed and a stop/limit order will be appended as a bracket order.
In the example below, the **Limit + Stop/Limit** option has chosen. The cursor will display LMT SL when hovering over the **Bid/Ask** columns. One left mouse click will create a limit order at that price and attach a stop and limit order above and below the current price.
**Adjusting Orders**

The price of a stop or limit order can be adjusted by dragging the order label up or down. The order ticket dialog can be displayed by double clicking on the order label. From this dialog you can change other attribute such as the **Time In Force** or the order quantity. An order may be cancelled by clicking on the ‘C’ button to the right of the order label.

![Image of Adjusting Orders](image)

**4.6.2 Position Panel**

The panel at the bottom of the DOM displays information on your current position and provides management options. It has the following elements:

1. **Position** – Current open position. This is displayed as quantity@average entry price. A blue background indicates a long position (red for short)
2. **P/L** – Current profit/loss. Blue background for profit, red for loss.
3. **Spread** – Difference between the bid and ask price
4. **Account** – account to use for placing orders
5. **Flatten Button** – Closes the open position at market price
6. **Cancel All Button** – Cancels all active orders for this instrument
7. **Reverse Button** – Reverses the currently open position at market price
8. **Buy Mkt Button** – Buys at market price using the quantity at the top of the DOM
9. **Sell Mkt Button** – Buys at market price using the quantity at the top of the DOM
4.6.3 Centering

In an active market, bid and ask prices may change quite rapidly. In some cases these values may appear above or below the current price ladder. The price ladder will automatically center itself in 5 second intervals, but you can manually re-center the DOM prices by clicking on the Re-Center button.

4.6.4 Preferences

DOM preference can be adjusted by choosing Options -> DOM Preferences from the top menu bar. Alternatively, click on the Preferences button on the tool bar. This dialog has the following fields:

1. **Rows** – number of rows to display in the DOM table
2. **Time In Force** – expiration for orders placed through the DOM
3. **Show Quantity Selector** – toggles the display of the bar that allows you to quickly choose a preset quantity
4. **Show Order Ticket Window** – if enabled the order ticket dialog will be displayed when creating an order from the DOM
5. **Double Click to Place Order** – if enabled a double click (instead of a single left click) will be required to create an order from the DOM
6. **Show Grid** – shows the outline around each cell in the DOM table
7. **Show Totals** – displays the totals bar at the bottom of the table
8. **Show Entry/Exit** – toggles the display of the Entry/Exit strategies panel at the bottom of the DOM

![DOM Preferences](image)

The columns displayed in the DOM table can be chosen from the plus button on the right hand side of the column header:

![Display Columns](image)
4.7 Option Chains

Groups of options (Stock and Future Options) can be managed from the Option Chain panel in the Console. If your broker supports options, you will see an “Options” page at the bottom of the Console window.

An option chain panel enables you to see the available options organized by strike price for a given expiry date. In the example below we are showing available options for AAPL that expire on Feb 24, 2017. By default 20 options (configurable) are displayed that are nearest the money. For convenience, a black divider line shows where the current price is trading for the underlying symbols.

Buy and sell orders can be placed directly from the option table by clicking on the Buy/Sell buttons that are next to each Put/Call pair. Current positions and profit/loss are also visible on the table for each option.

4.7.1 Placing and Managing Orders

The easiest way to place a limit or stop order is to click on the Buy or Sell button next to the call or put option that you would like to trade. When you click on this button an Order Ticket dialog will appear that will enable you to adjust the order. Defaults such as Account, Quantity and Time In Force can be set at the bottom of the panel.
Open orders can be canceled by clicking on the 'C' button next to the order. All open orders in the option chain can be cancelled by clicking on the Cancel All button in the bottom right corner.

Market orders can be placed by using the buttons in the bottom left corner. These orders will be placed on the put/call option that is selected in the table above.

If you have open positions, these can all be closed by clicking on the Flatten button in the bottom right corner.
4.7.2 Option Spread Strategies

MotiveWave™ supports several common spread strategies:

1. Vertical
2. Calendar
3. Diagonal
4. Straddle
5. Strangle
6. Back Ratio
7. Synthetic
8. Butterfly
9. Condor
10. Iron Condor
11. Vertical Roll
12. Double Diagonal
13. Double Calendar

The spread strategy can be chosen when creating an option order (click on the Buy/Sell buttons on the option chain table).

4.7.3 Preferences

Preferences for the Option Chain can be modified by clicking on the Preferences button (gear icon) in the top right corner. This dialog has the following elements:

1. **Max Rows** – Maximum number of rows to display for the option chain. Click on Show All Options to display all available options
2. **Show Calls/Puts** – By default both calls and puts are displayed in the table. This drop down allows you to choose Calls or Puts or both.
3. **Table Font** – Font and size for the text displayed in the table
4. **Show Grid** – Displays a border around each cell in the table
5. **Sort Descending** – Sorts descending by strike price  
6. **Show Order Ticket** – Shows the order ticket dialog when placing a market order  
7. **Show Order Panel** – Shows the section at the bottom of the option chain for managing orders  
8. **Show Quote Panel** – Shows the quotes for the underlying symbol at the top of the panel  
9. **Update Button** – Applies these changes and closes the dialog  
10. **Call Columns Button** – Click on this button to choose the columns displayed for Call Options  
11. **Put Columns Button** – Click on this button to choose columns displayed for Put Options  
12. **Save Defaults Button** – Saves these settings as the default for other Option Chain panels  
13. **Cancel Button** – Cancels changes and closes the dialog.

### Option Chain Preferences Dialog

![Option Chain Preferences Dialog](image)

Call and Put columns can be adjusted by clicking on the **Call Columns** or **Put Columns** button (see dialog above). The columns available will depend on what is supported by your broker. The dialog below shows available columns for Tradier Brokerage.

### Choosing Call/Put Columns

![Choosing Call/Put Columns](image)

Select columns on the left or right and use the '>' and '<' buttons to add or remove them. Use these buttons to change the column order.
5 Desksops

Desktops provide a convenient way to organize charts and other panels in one window. A Desktop is essentially another Console window and uses the same docking framework to layout pages.

Choose File -> New -> Desktop from the Console menu bar to create a Desktop window.

Create Desktop Window

Enter a unique name for the Desktop from the New Desktop dialog and click the OK button to create.

New Desktop Dialog

The follow screen shot shows the default layout for a Desktop window when it is first created. The default layout includes two pages: Charts and Charts 2.
To open or manage existing Desktops, select File -> Open -> Open Desktop from the Console menu bar:

When you close a Desktop (by clicking on the ‘X’ button in the top left corner), the group is not deleted but still exists in the repository. If you want to permanently remove a Desktop, select it in the Manage Desktops dialog and click the Remove button.
5.1 Changing Desktop Layout

Since a Desktop is essentially another Console window, see the section: Changing the Default Layout for details on how to configure a custom layout.
6 Scanner

MotiveWave™ has a built-in scanner for looking for trade setups across a given set of instruments and bar sizes. There are three types of patterns that you can search for:

1. **Elliott Wave** – Elliott Wave patterns such as Wave 2, 3, 4, 5 and Wave E (in a triangle)
2. **Gartley** – Harmonic patterns including all XABCD type patterns, AB=CD, 5-0 and Alternate AB=CD
3. **Study Conditions** – Criteria based on study values

When you first start MotiveWave™ you will see a page at the bottom of the window named *Scan*. Click on the page tab to show the screen below.

### 6.1 Creating a Scan (Gartley Scanner)

If you would like to create a new scan, choose **New Scan** from the **Choose Scan** drop down or press the **New Scan** button on the right hand tool bar of the scanner panel. This will open a wizard that will guide you through the process of creating a scan.

The screenshot below shows the first page of the scanner wizard. Enter a name for the scan and select the type of scanner from the drop down below. In this example, we will choose Gartley as the type.
On the next page of the wizard, you will be prompted to select 1 or more instruments and/or watch lists. If a watch list is chosen, all of the instruments that are in the watch lists will be included in the scan. The order of the instruments and watch lists will be considered when the scan is executing.

Click on the Add button to add a bar size to the list box. Any size linear bar or non-linear bar (ie Range, Renko, etc) may be added. Check the Extended Data box at the bottom of the dialog to use data that is outside of regular trading hours.
The final page of the Gartley scanner wizard enables you to choose the type of Gartley pattern to search for as well as the historical data range where the pattern may occur. If you would like to search for all forms of the XABCD pattern (i.e., Gartley, Bat, Butterfly, Shark, etc.) then choose XABCD (All) as the pattern.

6.2 Executing a Scan

The following screen shot shows the new scan ‘Gartley XABCD Patterns’ that we created above and the results from running executing it on the latest available data. If you would like to execute this scan,
select it from the drop down and press the **Start** button (see below in the upper left scanner panel). The progress bar will show how far the scan is progressing (see upper right scanner panel below).

Results will display in the table area of the scanner panel as they are found. This table will display:

1. **Symbol** – instrument where the pattern was found
2. **Bar Size** – Bar Size the pattern was found on
3. **Scan Time** – When the pattern was found
4. **Pattern** – The specific pattern that was found
5. **Score** – Score rating: Fair, Good, Very Good, Excellent

To display a scan result in the chart panel below left mouse click on the table row. **Note:** this will only work if the **Link** button is selected (see top right button area for the scanner panel below)

The results displayed in the scanner table are **unnamed analyses** that are kept in computer memory. If not explicitly saved, these analyses will disappear the next time you execute the scan or if MotiveWave™ is restarted. When one of these results is opened in a chart window or panel, you may save the analysis to the repository by clicking on the **Save** button (see tool bar).

You may find that the full pattern that was found is not entirely visible when you display it in the chart. Click and drag the time axis to the right to zoom out or select a higher bar size.

**6.3 Editing a Scan**

You can edit a scan to change its instruments, bar sizes or criteria. Select the scan from the drop down in the scanner panel and click the **Edit** button from the button area in the top right corner of the panel. Alternatively, click on the **Manage Scans** button to open the **Manage Scans** dialog.
The Manage Scans dialog enables you to create, open, edit, rename or remove existing scans. Select a scan from the list area and use the buttons on the tool bar to open, edit or delete existing scans.

The Edit Scan dialog provides options to adjust properties from the General tab. Optionally change the name of the scan.

Select the scan from the drop down and click the Edit button.
6.4 *Elliott Wave Scanner*

The example shown above is for the Gartley scanner. You can also search for Elliott Wave patterns by choosing *Elliott Wave* as the type when you create a new scan. Selecting instruments and bar sizes is the same for all scan types.

On the *Specify Criteria* page you can choose the Elliott Wave pattern that you are searching for. The following patterns are currently supported:

1. **Wave 2** – This will search for an Elliott Wave pattern when the top level wave is currently in a Wave 2. Wave 2s are commonly used as trading setups since wave 3 tends to be the longest wave.
2. **Wave 3** – Finds patterns where the top level wave is currently in wave 3
3. **Wave 4** – Finds patterns where the top level wave is currently in wave 4
4. **Wave 5** – Find patterns where the top level wave is currently in wave 5
5. **Wave E (Triangle)** – Finds patterns where the top level wave is in wave E of a triangle

The *Decompose Levels* specify how many levels down the top level wave should be decomposed in to smaller waves. Choose *Decompose All* to decompose the wave to all possible levels.

The Minimum and Maximum bar settings can be used to define the historical data range. If you check *Use All Available Data* MotiveWave™ will load all data from the local database.
The following screen shot shows the results of searching for a Wave 2 pattern. To view a particular result, click on the row in the results table. You may need to zoom the chart out to see the full pattern depending on how much data you specified in the scan criteria.
6.5 Study Scanner

The study scanner enables you to search for study conditions that include 1 or more studies. When you create a new scan, choose Study as the type from the Type drop down. Selecting instruments and bar sizes is the same for all scan types (see Creating a Scan (Gartley Scanner) section for details).

On the Choose Studies panel, you can select one or more studies to include as part of the scan. Click on the add study button to add a study to the list box below. When you click this button, you will be able to search for the study that you want to add and configure its settings (see following screen shots).
Add Study Dialog

In the screenshot below, we have added one study to the scan, RSI(C,14). Additional studies could be added by clicking the add button. In this example, we are just going to work with one study.
The last page of the scanner wizard asks you to define the criteria for evaluating the scan. Click on the add condition button to add a condition to the list. There are two types of evaluation methods:

1. **All** – In this method, all conditions defined on this page must be met in order for it to be considered a match. This is the default evaluation method.
2. **One or More** – In this method, only one of the conditions defined on this page must be met for it to be considered a match for this scan.
3. **Lookback Bars** – Number of bars to look back and evaluate the study criteria. 0 indicates the most current bar.
In the **Study Condition** dialog (see below) you can define a condition based on a variable that is generated from one of the studies you defined. A variable may be compared against a specific value or compared against another variable. The fields in this dialog are as follows:

1. **Study** – Choose the study that you configured on the Choose Studies page
2. **Bar Index** – In most cases the comparison is done with the current bar, but you may choose historical bars by choosing a specific index
3. **Variable** – This field will be populated when you choose the study. Each study will export 1 or more variables. You can see these variables in the Cursor Data Window/Panel
4. **Operator** – This is the comparison operator for comparing the variable to the value. Valid options include: > (greater than), >=, < (less than), <=, = , Crosses, Crosses Above, Crosses Below
5. **Relative Comparison** – Indicates if the variable should be compared against a specific value or against another variable.
6. **Value** – If not a relative comparison, this field will contain the specific value you are comparing against.

If you checked the Relative Comparison option, the dialog will change to allow you to choose a study and variable for comparison. The Price Bar option allows you to compare to the Open/High/Low/Close values of the price bar. In the example below, two EMAs were added to the studies list and its comparing the EMA(C,20) value to the EMA(C,50) value to see if the first value is above the second.

The screen shot below shows the results of running this scan. In this case we only found one result where the RSI value is greater than 80.
Study Scanner Results

In this case we found 2 results where the RS value is above 80.
7 Strategy Back Testing

Strategy back testing is a special type of historical testing that allows you to determine how a strategy would have performed if it had actually been run during past historical time periods and market conditions. It does not guarantee how your strategy will perform in future market conditions, but will allow you to identify any potential issues or vulnerabilities against past market conditions. This allows you to ‘test’ and tweak your strategy without having to place actual trades. See the Wikipedia page on strategy back testing for more information.

MotiveWave™ has highly advanced strategy back testing options through our Strategy Optimizer. The default layout of the MotiveWave™ Console has a page called Optimize (see bottom of the console window). Click this tab to show the strategy optimizer page.

7.1 Creating a Strategy Analysis

From the Optimize tab of the Console, click on the New Analysis button (see screen shot above). This will launch a wizard that will walk you through the process of creating an analysis of your selected strategy.

MotiveWave supports 3 types of Strategy Analysis:

1. **Back Test** - This option enables you to execute your strategy with specific settings over a given set of instruments and a specific bar size/time frame. This can be useful to determine how your strategy may have performed with past data and specific settings.
2. **Optimize** - The profitability of a strategy will vary depending on how it is configured. This option will enable you to specify a range of settings for the strategy and test many different combinations of these settings to determine which combination is "optimal".
3. **Walk Forward** - Sometimes knowing the optimal settings for a specific range of data is not enough. Just because a strategy performed well for a specific bar size and time frame does not
guarantee that it will continue to perform well in the future. Walk forward testing helps to mitigate this problem by stepping forward in time after every iteration of a time frame.

The following screen shot shows the first panel of the New Strategy Analysis wizard. From here you can choose your strategy and specify the type of analysis you wish to perform.

![New Strategy Analysis Wizard](image)

7.1.1 Strategy Settings Panel

Once you have chosen the strategy and analysis type, click on the Next button to specify the settings for the strategy. If you chose Back Test, then you will just need to specify the specific settings for this strategy (see below). In this case we have chosen the "MA Cross Strategy":

![Strategy Settings Panel](image)
Alternatively, if you chose **Optimize** or **Walk Forward** as the type, the next page of the wizard will look more like the following screen shot. This panel will enable you to specify the range of possibilities for the configuration of the strategy. MotiveWave™ will build combinations of the strategy settings based on this input.
7.1.2 Choose Instruments Panel

The next page of the wizard allows you to choose the set of instruments (symbols) for the analysis. A specific set of instruments may be chosen by clicking on the **Add Instrument** button or the **Search Instrument** button. Additionally, you may specify one or more watch lists to specify a group of instruments.

![Choose Instruments Page](image)

**7.1.3 Data Settings Panel**

If you choose **Back Test** or **Optimize** as the analysis type, then your data settings panel will look like the following. This panel allows you to choose the range of data and bar size for the analysis. Ideally you should use historical tick data (see **Source Data** field) for the analysis since this will give the closest approximation of a real world test. Unfortunately not all brokers or data services provide this data (or enough of it). In these cases you can generate ticks from either the source data or 1 minute bars.
The walk forward data settings are a little bit different. Two more parameters are available to define the **Optimize Period** and **Walk Forward Period**. **Optimize Period** defines the size of the optimization window (the number of days to include in each walk forward iteration). If the **Anchor** option is enabled, the Start Date will remain fixed for each iteration. Effectively, this means that the optimize period will increase by the walk forward period each walk forward iteration (ie: 60, 90, 120 etc days in this example).
7.1.4 Execution Settings Panel

Execution settings specify the runtime behavior for the analysis. Commissions can be included in the profit/loss calculation and can be configured from the Console menu bar (Configure -> Commissions). Slippage can also be enabled to account for market orders. During periods of lower volume market orders may not be filled at the current bid/ask prices. This parameter assumes that the order will be filled the given number of ticks away from the bid/ask price.

![Execution Settings Panel]

7.1.5 Optimizer Settings Panel

If you chose Optimize or Walk Forward as the analysis type, then you will see the Optimizer Settings panel as the last panel in the wizard. MotiveWave currently supports two types of optimizer algorithms:

1. **Exhaustive** - this algorithm will evaluate all combinations of the strategy settings to find the optimal result. This algorithm will find the optimal settings for the strategy. This is a good option if the number of combinations is relatively low.
2. **Genetic** - employs a natural selection approach to find an optimal combination without having to evaluate all possible combinations of the strategy settings. For more details on how this works see Wikipedia: Genetic Algorithm.

7.1.5.1 Exhaustive Optimization vs. Genetic Optimization

There are many types of optimization. The most common types used for strategy optimization are Exhaustive Optimization and Genetic Optimization. Both types of optimization have benefits. It’s just a matter of figuring out which type of optimization is most appropriate for the results you’re looking for.
7.1.5.2 Exhaustive Optimization

Exhaustive Optimization will run through and test every possible combination of inputs to determine the absolute best possible performance solution. But, because it will run through every possible combination, running an exhaustive optimization can take a very long time. The time required to run an exhaustive optimization is dramatically increased when a large number of inputs or parameters are used in the search.

To reduce the amount of time required to run the exhaustive optimization, you can limit the number of inputs or parameters used to a small number, or use genetic optimization instead.

7.1.5.3 Genetic Optimization

Genetic Optimization (or Genetic Algorithm Optimization) is based on the concept of biological evolution, or natural selection. In relation to trading strategy optimization, genetic optimization will start by randomly selecting a number of combinations to test. From those selected, it will determine which of those combinations have the best potential and discard the rest. Then it will continue to test the remaining ‘best potential’ combination candidates until it arrives at the close-to-best input or parameter performance solution.

Because genetic optimization does not test every possible combination, it will not arrive at the absolute best possible performance solution, like with exhaustive optimization, but the time it takes to arrive at a close-to-absolute best performance solution is dramatically shorter.

Genetic Optimization is best suited for running an optimization with many inputs or parameters. The larger the sample size is, the longer it will take to complete the optimization, but if the sample size is too small, the genetic optimization results may be less accurate.
7.2 Strategy Analysis

Once you have created and executed a strategy analysis, you can look at the results in the strategy optimizer (see below). The analysis will contain one or more execution instances in the summary table at the top of the window. Select the instance that you want to view and it will be displayed in the panel below the table.

The following screen shot shows an example of the Chart tab of the strategy analysis. This tab displays a visual representation of the executed trades that occurred for the selected execution instance.
Several visual reports are available under the Reports tab. The available report types can be found in the Report dropdown.
The **Periods** tab groups trades together based on the selected period (hourly, daily, weekly, etc.). Each row in this table displays summary information.

The **Trades** tab shows all of the trades that occurred. A trade includes the entry into the trade as well as the exit out of the trade. This allows you to see the profit/loss that occurred with each trade.
The **Executions** tab displays all of the filled orders.
8 Custom Instruments

MotiveWave™ allows you to create custom instruments that are based on 2 or more existing instruments. There are 3 types of custom instruments:

1. **Spread** – Displays the difference between two instruments
2. **Ratio** – Displays the ratio by dividing the price of one instrument by another
3. **Index** – Allows you to combine the prices of 2 or more instruments into an index

To create a new custom instrument, choose `File -> New -> Custom Instrument` from the Console menu bar:

This will open a wizard to guide you through creating a custom instrument. You will need to enter a unique symbol for the instrument (it cannot match any existing instrument in the workspace). In the following example we are going to create a custom index (US Dollar Index). The minimum tick value specifies the minimum amount for each change in the instrument price.
The US Dollar Index measures the relative value of the US Dollar vs a set of foreign currencies. For more information see the definition on Wikipedia: https://en.wikipedia.org/wiki/U.S._Dollar_Index. In this case we need to include 6 different currency pairs and use the exponent option to assign a weight to each one (Note: EUR/USD and GBP/USD need to be inverted):

1. **EUR/USD** – 57.6% weight (inverted) (Euro dollar)
2. **USD/JPY** – 13.6% weight (Japanese Yen)
3. **GBP/USD** – 11.9% weight (inverted) (British Pound)
4. **USD/CAD** – 9.1% weight (Canadian Dollar)
5. **USD/SEK** – 4.2% weight (Swedish Krona)
6. **USD/CHF** – 3.6% weight (Swiss Franc)

These values are multiplied together and then multiplied by 50.14381 (see link above for the reason for this number).

The following chart shows daily candles for the custom index that we created above. Incoming price updates will also be calculated using the formula that was defined for the instrument.
Custom instruments can be edited/managed from the **Manage Instruments** dialog (**Configure** -> **Instruments** from the Console menu bar). The easiest way to display all custom instruments in the workspace is to sort the table by the **Type** column (ascending). If you double click on a custom instrument, the **Custom Instrument Wizard** will be opened allowing you to edit the instrument.
The following table contains the instruments that currently exist in the local database. From this dialog you can add, remove or edit instruments by double-clicking or selecting multiple rows.

### Manage Instruments

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Type</th>
<th>Currency</th>
<th>Exchange</th>
<th>Description</th>
<th>Source</th>
</tr>
</thead>
<tbody>
<tr>
<td>CAD Oil</td>
<td>Custom</td>
<td>USD</td>
<td>NONE</td>
<td>Canadian Dollar Vs US Oil Ratio</td>
<td>FXCM</td>
</tr>
<tr>
<td>US Index</td>
<td>Custom</td>
<td>USD</td>
<td>NONE</td>
<td>US Dollar Index</td>
<td>FXCM</td>
</tr>
<tr>
<td>USDollar</td>
<td>CFD</td>
<td>USD</td>
<td>FXCM</td>
<td></td>
<td></td>
</tr>
<tr>
<td>JPN225</td>
<td>CFD</td>
<td>JPY</td>
<td>FXCM</td>
<td></td>
<td></td>
</tr>
<tr>
<td>GER30</td>
<td>CFD</td>
<td>EUR</td>
<td>FXCM</td>
<td></td>
<td></td>
</tr>
<tr>
<td>FRA40</td>
<td>CFD</td>
<td>EUR</td>
<td>FXCM</td>
<td></td>
<td></td>
</tr>
<tr>
<td>ITA40</td>
<td>CFD</td>
<td>EUR</td>
<td>FXCM</td>
<td></td>
<td></td>
</tr>
<tr>
<td>SUI30</td>
<td>CFD</td>
<td>EUR</td>
<td>FXCM</td>
<td></td>
<td></td>
</tr>
<tr>
<td>ESP35</td>
<td>CFD</td>
<td>EUR</td>
<td>FXCM</td>
<td></td>
<td></td>
</tr>
<tr>
<td>HKG33</td>
<td>CFD</td>
<td>HKD</td>
<td>FXCM</td>
<td></td>
<td></td>
</tr>
<tr>
<td>AUS200</td>
<td>CFD</td>
<td>AUD</td>
<td>FXCM</td>
<td></td>
<td></td>
</tr>
<tr>
<td>NAS100</td>
<td>CFD</td>
<td>USD</td>
<td>FXCM</td>
<td>NASDAQ 100</td>
<td></td>
</tr>
<tr>
<td>SPX500</td>
<td>CFD</td>
<td>USD</td>
<td>FXCM</td>
<td>S&amp;P 500</td>
<td></td>
</tr>
<tr>
<td>US30</td>
<td>CFD</td>
<td>USD</td>
<td>FXCM</td>
<td></td>
<td></td>
</tr>
<tr>
<td>USOIL</td>
<td>CFD</td>
<td>USD</td>
<td>FXCM</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Total Instruments: 468

- **Sort by type ascending**
- **Double click or select and press the **Edit** button below.**
- **Click here to define a new custom instrument**